Ico - unable to climb chain to the top.
# PCSX2 version: Official 0.9.7 Beta 3876/3878; Official 0.9.6 release.
# CPU options: default
# Plugins used: GSdx 3693 (MSVC 15.00, SSEE41) 0.1.16; Lilypad 0.10.0; cddvdGigaherz (r3429)
#OS: Windows 7 Home Premium x64
All options default, no speedhacks, bios euro 2.0

Ico PAL version.

[Image: 788d9963f671cd400406bb509e4ef.png]

Story: I get from left wooden bridge to the chain, and then on stone platform, spin the gear to move big box - way for Yorda. Then I come back the same way, and can't reach the wooden bridge..

The screenshot shows maximum height I can climb the chain.

I tried to jump all 4 directions, tried to drop from ledge to a small window...

I used 0.9.6 official, which was running game very bad; and latest beta (I'm using 3876) - with the same result.

Help me.

Sponsored links

You can also swing using 'O', so you can jump further (to the right side maybe? I don't recall the solution for this specific puzzle though).

Also, Ico runs relatively very fast on PCSX2 (on my system it can run at almost double speed on average). Start with default settings, then apply the recommended speed hacks. You can also use EE cycle rate and VU cycle steal. Ico get's faster with those (to a degree).
Lol, you saved my life, I didn't know that it's possible to swing...

Thanks alot :]

Users browsing this thread: 1 Guest(s)