Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Illegal instruction (core dumped)
#1
I keep getting a crash. The terminal says Illegal instruction (core dumped)

I am trying to run PCSX2 1.5.0-0 installed from this ppa : deb http://ppa.launchpad.net/pcsx2-team/pcsx2-daily/ubuntu bionic main

os : Linux Mint 19 Cinnamon
cpu : Intel© Pentium© CPU G4560 @ 3.50GHz × 2
gpu : Radeon RX 470
ram : 7.7 GiB

Little history, I first installed 1.4.0 from the gregory ppa, https://launchpad.net/~gregory-hainaut/+...ficial.ppa. I was able to configure pcsx2 1.4 with default settings and run Scarface The World is Yours, but it was really slow and buggy. I found more than one post saying use the unstable version and the VU I-Bit Hack and it would run fine. So installed PCSX2 1.5.0-0, but I immediately got a failed to configure gs plugin error. When I clicked ok, the program would crash with the Illegal instruction (core dumped). So, I chose "cancel" at the failed to configure popup, and poked through the PCSX2 menu until I managed to reset and clear the configuration. Now, I get the first time set up screen when I run PCSX2, click next on the first time configuration, then choose "overwrite" on the "Import configuration" dialog(apparently it still finds the previous configuration from 1.4), then the program crashes and I get the same error, Illegal instruction (core dumped). So, any help, ideas would be greatly appreciated.

output from terminal:

[email protected]:~$ PCSX2
Interface is initializing.  Entering Pcsx2App:OhmynInit!
Applying operating system default language...
Command line parsing...
Command line parsed!
Illegal instruction (core dumped)
Reply

Sponsored links

#2
Make sure that you are not using AVX versions of plugins. Pentium family lack of AVX, AVX2 and FMA3 support.
Reply
#3
(08-27-2019, 02:12 PM)kozarovv Wrote: Make sure that you are not using AVX versions of plugins. Pentium family lack of AVX, AVX2 and FMA3 support.
PCSX2 1.4 worked on my machine, it just that Scarface was unplayable. There is a couple posts out there that says 1.5 has some new hacks that will run Scarface. I can look those up again later if need be and put links here. It's just that I can't get 1.5 to get past the configuration screen without crashing.

If I 
Code:
sudo apt-get install pcsx2

1.4 installs over 1.5 and it will run, and Scarface will run, it's just slow and buggy.

If I then
Code:
sudo apt-get install pcsx2-unstable
1.5 installs over 1.4 and pcsx2 crashes before the configure screen can open.

Are you saying that the daily-unstable ppa uses different plugins for 1.4 and 1.5? Why would the plugins work on 1.4 and not 1.5? Should I delete the plugins from 1.4 before installing 1.5? Shouldn't the "sudo apt-get install pcsx2-unstable" overwrite the plugins from 1.4 with the correct versions for 1.5?

Thanks for the reply, but I am confused even more now. Also, I am a complete noob with PCSX2, so when you say "AVX, AVX2 and FMA3 support", I have no clue what that means.
Reply
#4
Afaik only GSDX plugin is using AVX/AVX2, and only when AVX version is selected. Error you get "Illegal instruction (core dumped)" is standard error that indicate one of x86 instructions that was used is not supported by your CPU.

I think this can be only caused by GSDX plugin on your setup, is hard to imagine that newest pentium not support anything else that pcsx2 use. Try to delete current plugins, maybe somehow AVX version is loading at default for you. No idea.

Anyway, when selecting GS plugin you should see SSE version, AVX version, etc. Most compatible is SSE2 version.
At the second hand is now described as SSE2/AVX, so maybe something really changed on pcsx2 side. That i can't answer. Tl;dr, try to delete plugins, and after recompile use SSE2 plugin.
Reply




Users browsing this thread: 1 Guest(s)