Inexplicably dark objects
I've been playing The Legend of Spyro: A New Beginning and recording its cutscenes, adding and removing 'CrcHacksExclusions=all' depending on the cutscene to get closer to how it's originally supposed to look like. (Without CRC hacks the game's main menu and HUD aren't visible and the game is often darker than it should be, like watching it through shades. CRC hacks in turn seem to remove most shadows in the game, making many areas more lit than they should be.)

Long story short, I'm using PCSX2 V1.0.0 (r5350) and the crystals in one world of the game don't glow like they're supposed to, and like they did when I played (and recorded) it with an older version/revision (think it was r4600, but I'm not sure)*. Even with CRC hacks on it looks darker than when it's natively played on a PS2, while the effect is opposite for pretty much everything else in the game.

* (If you're wondering why I'm recording them again, it's because I later realised I could've used fxaa=1 and Shade Boost, as well as encode with h.264 rather than h.263; all of this for clearly better looking video.)

[Image: 17eZ7.jpg]

Again, I'm not sure of the exact revision in which the bottom pic was taken, but it was soon after a SVN build fix before which the main menu and HUD of LoS:ANB weren't visible by default (guessing it was the initial CRC hackfix).

Is there any possible cause to this that an expert could tell from a glance? I've tried switching between GSdx9 and 11, enabling and disabling Shade Boost, etc... I even tried downloading and using V0.9.8 (r4600) but I couldn't play the game because it'd crash pretty soon after loading the migrated save file. (No idea why...)
- Tried switching between GSdx 9 and 11 doesn't work
- Downloaded and tried using V0.9.8 r4600 to play that part - unplayable, keeps crashing (dunno why)
- Works correctly in Software mode, but doesn't help my case since my quest is to record in 1920x1080

This might not seem important...but I'm recording all the cutscenes of the game, and this level / world looks decidedly unimpressive if it's as dark as it is now. =\

Thanks in advance for any help you can provide. I can provide more samples if needed, since I have a video clip of both versions. (Took the pictures from those clips.)

Update: Shows correctly in 0.9.9 r4832. What could be the problem in 1.0.0 and up?

Sponsored links

go here

try some random builds between r5325 and the r4832 you have. see if you can narrow down to where it was broken Smile
[Image: ref-sig-anim.gif]

Try 4839 (ie find the closest revision to that, that has the bug)
[Image: newsig.jpg]
Noted, I'll see if I can narrow it down. (Will take some time since I'm busy doing other things now.)

Users browsing this thread: 1 Guest(s)