Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ingame Lighting Issue
#1
Hi, I apologize if this thread was posted in the wrong thread.

I downloaded PCSX2 a few days ago because I wanted to play my childhood game again but after I boot and start the game, the lightings in the game seemed weird and flickered a lot. I first booted up the game with some changes on the GSdx settings, namely Internal Resolution (3x), Anisotropic Filtering (4x), and enabling FXAA. The game didn't seem right so I closed it and tried to revert back to default by setting Internal Res back to Native, turning off Anisotropic Filtering and disabling FXAA, then booted it again but the game still flickers. Below I've attached some screenshots for example.

I've tried searching on google for related lighting issues, but most of them are gamebreaking or heavily lagging when there's lightings involved, which are not really related to my case. Mine isn't that big of an issue to that I can't play it, but its really annoying to have those lights spazzing out all the time.

I hope this issue can be fixed soon ><



P.S I uses GSdx9 as it is the default for me.


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
Via PCSX2 wiki:

Quote:1.5.0 (dev-2011-g16904d5)

The game is "Playable" only in status. There are major visual issues that cause the 
screen to flash rapidly and could induce seizures. Changing the Renderer or any GSdx settings help. This has been an issue since at least 2012. 30FPS at all times.

Btw. @hamooda3000 you don't even mention game name..
Reply
#4
@CK1

My computer specs:-
Processor: Intel® Core(TM i7-7700 CPU @3.60GHz, 3601Mhz
Graphics Card: NVIDIA GeForce GTX 1070
RAM: 16GB
Operating System: Windows 10 64-Bit

Version of PCSX2: 1.4.0
No hacks or cheats were used
Image of GSdx9 settings: https://imgur.com/eYjyWVY
Game: Musashi: Samurai Legend on ISO

@kozarovv The game I was trying to play was Musashi: Samurai Legend
Reply
#5
Download the latest dev build here and switch to OpenGL: https://buildbot.orphis.net/pcsx2/
Reply
#6
@kozarovv I've just finished trying each renderer like what the quote suggested, with no settings changed. Below are the results,

OpenGL (Hardware) - Better lighting but still has some flickers
Direct3D11 (Hardware) - Worst lighting, half the screen is pure white at certain scenes
Direct3D9 (Hardware) - Not any much better than Direct3D11
All the software ones only makes the screen freeze, although I can still hear the audio going.
Reply
#7
@CK1 I downloaded v1.5.0-dev-2418-gba1689f6d by refractionpcx2 and booted the game with OpenGL, but the issue with the lights flickering is still there
Reply
#8
(06-21-2018, 06:49 AM)hamooda3000 Wrote: @CK1 I downloaded v1.5.0-dev-2418-gba1689f6d by refractionpcx2 and booted the game with OpenGL, but the issue with the lights flickering is still there

ok.
means the bug is still not solved.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
(06-21-2018, 06:49 AM)hamooda3000 Wrote: @CK1 I downloaded v1.5.0-dev-2418-gba1689f6d by refractionpcx2 and booted the game with OpenGL, but the issue with the lights flickering is still there

You may try this cheat patch but it remove all the special effect.https://forums.pcsx2.net/Thread-Fixing-unplayable-games?pid=568899#pid568899
I am still waiting for his help to fix the game.
Try to ask prafull maybe he had the fix but didn't post up.
Reply
#10
(06-21-2018, 03:23 AM)hamooda3000 Wrote: Hi, I apologize if this thread was posted in the wrong thread.

I downloaded PCSX2 a few days ago because I wanted to play my childhood game again but after I boot and start the game, the lightings in the game seemed weird and flickered a lot. I first booted up the game with some changes on the GSdx settings, namely Internal Resolution (3x), Anisotropic Filtering (4x), and enabling FXAA. The game didn't seem right so I closed it and tried to revert back to default by setting Internal Res back to Native, turning off Anisotropic Filtering and disabling FXAA, then booted it again but the game still flickers. Below I've attached some screenshots for example.

I've tried searching on google for related lighting issues, but most of them are gamebreaking or heavily lagging when there's lightings involved, which are not really related to my case. Mine isn't that big of an issue to that I can't play it, but its really annoying to have those lights spazzing out all the time.

I hope this issue can be fixed soon ><



P.S I uses GSdx9 as it is the default for me.

Try switching to software mode (you can do this in-game by pressing F9)
Reply




Users browsing this thread: 1 Guest(s)