Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Input Lag
#1
I'm getting input lag in both games I've tried, The Warriors and Onimusha: Warlords. I'm using a PS2 Dualshock 2 controller via a usb adapter that uses Xinput software, everything works fine, including the emulator with those two games (flawless). I've also tried my Xbox One controller that uses DirectInput software with no difference. I read some threads via the search function and there was one poster who offered some suggestions and I tried them but to no avail.

Running PCXS2 version 1.5 revision 3b122a1

Images of my PCXS2 configuration here,
https://imgur.com/a/BH6EN

PC Specs,
CPU: i7-6700k Skylake
GPU: Asus 1070
RAM: 16GB G.Skill Trident
OS: Windows 10 64-bit
Running PCXS2 off an SSD

Any suggestions are very appreciated, thanks!
Reply

Sponsored links

#2
What Directainput/XInput software are you using to interface with your controllers? Can you also get a screenshot of your Lilypad settings?

Side note: You can crank up your GSdx settings a bit more. You should have Accurate Date enabled and Blending Unit Accuracy could be bumped High/Full depending on the game. I would also disable Large Framebuffer.
Reply
#3
(11-17-2017, 05:46 PM)CK1 Wrote: What Directainput/XInput software are you using to interface with your controllers? 
I'm not sure I understand the question. I just plug 'em in and then configure with PCSX2.

(11-17-2017, 05:46 PM)CK1 Wrote: Side note: You can crank up your GSdx settings a bit more. You should have Accurate Date enabled and Blending Unit Accuracy could be bumped High/Full depending on the game. I would also disable Large Framebuffer.
Just curious, how come? What will changing these settings do?
Reply
#4
Oh sorry, I misread that. Can you post the dialog screeenshot of your Lilypad settings?

Changing your GSdx settings will make your games look better, and I'm saying that because I know your PC can handle it.
Reply
#5
Sure, is this it?

https://imgur.com/a/6ujaU
Reply
#6
Yes, I would try disabling DirectInput and Pad 2.
Reply
#7
(11-18-2017, 08:32 AM)CK1 Wrote: Yes, I would try disabling DirectInput and Pad 2.

I tried disabling DirectInput but didn't notice any difference. Dumb question but how do I disable Pad 2? I cleared all the keybindings but I can't find if there's a hard disable I'm missing. Googled it but don't see anything.
Reply
#8
LilyPad>General(Tab)>Pads(section):
Click Pad 2 and on the right there's a drop-down menu. Select "unplugged".
Reply
#9
Thanks, I found it and unplugged it but nothing's changed. Is there a way via software or something where I can test my controller's input delay either outside or inside PCXS2? Just to make sure I wasn't crazy I tested both controllers in Middle Earth: Shadow of War and Titanfall 2. Both were noticeably snappier with the controls. I'll try to take a video later today. I'd compare it to playing on a streaming service with so-so internet. It's playable for 90% of games, but it's really not ideal, annoying when you can't stop thinking about it, and I'd never play it with a fighting game or fast-paced action game.
Reply
#10
You can "disable desktop composition" under proporties->compatability for the pcsx2 exe you use. That'll cut off a frame or two of lag. You have an nvidia card so you can also go into the nvidia control panel (or nvidia inspector which is way better) and make a profile for pcsx2 and lower the max pre-rendered frames to 1 or 2. 2 might be slightly smoother (but probably not lol), at the cost of a little bit more latency.

Also, disabling vsync will cut a bunch of lag, if you use that. Or if you really want vsync, there's a trick you can do with that too. Basically get a program like RTSS(it comes with msi afterburner) and use it to limit the framerate to 59. That will cut vsync lag by a lot. There's actually an even better way to do it, that avoids the stutter caused by dropping 1 frame every second but it's a little more complicated. I'll explain it if you want.
#StopRNG
Reply




Users browsing this thread: 1 Guest(s)