Intel GMA 4500, ArchLinux, ZZogl: broken graphics
Intel GMA 4500MHD (the rest of the hardware doesn't matter, for it's a purely graphics bug)
pcsx2 rev4260

The problem is: no matter, what options/hacks I set or unset, I get a borked picture. Textures and polygons are ok, but covered with "stripes" and other artifacts. The text is impossible to conceive, it's turned into some unimaginable geometric figures.
I'm sitting with this problem for the whole day. Any help is greatly appreciated.
Also, I must say, I'm new to pcsx2 (haven't played a single a game). And I have only FFX discs, don't ask to test it with other ones.
I have a wild guess, that it's somewhat connected to my system: mesa, libgl or whatever. I just don't know, what to debug, and what way.
Thank you very much for attention.

Just tried with rev3800 - essentially the same thing.

Attached Files Thumbnail(s)

Sponsored links

It is not a PCSX2 issue.

I thinks your card does not support correctly opengl. I do not know if it is a driver or hardware limitation. Get a real gpu (ie not an intel one).
How can it be a hardware limitation, while other people use pcsx2 with such a GPU successfully? Futhermore, FFX shows me 100% FPS, it runs smoothly (first two-three minutes, then my patience ceases).
Anyway, thanks for the answer, I was waiting for it to be like that. If you are sure, that it's not pcsx2 issue, then I'll try to run a win32 version in VM.
Did people uses directx or opengl. Well it is most probably a driver rather than an hardware. It is still an intel issue Tongue2. I do not know if opensource driver can improve a little the situation.

Actually FFX do not need lots of power that could work. I'm interest on your return on the win32 vm.
Well, console output could lid a little light into it.
Is Intel GMA 4500MHD integrated grafic in mobo ?
(01-26-2011, 12:15 PM)Zeydlitz Wrote: Well, console output could lid a little light into it.
A bit later, when I have time, I'll build a debug version and paste the output.

(01-26-2011, 04:53 PM)Game Wrote: Is Intel GMA 4500MHD integrated grafic in mobo ?
Yes, it is. Integrated in Intel GM45 (mobile) chipset.
4.0 Shader model, OpenGL 2.1 and DirectX 10 hardware support.
It's a previous generation to those, called Intel GMA HD, integrated in i3/i5/i7 processors.
Intel GMA is known to cause issues under Win32/GSdx as well.
It's Intel not being able to release working drivers.
Hint: Try to find the latest drivers available, could be they fixed it by now.

Users browsing this thread: 1 Guest(s)