Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Internal resolution scaling apparently not working
#1
Greetings.

I've got the issue with many games that changing the internal resolution does not seem to properly apply to the outputted image (there's an improvement but even at 8x resolution you can notice the pielation). This includes but is not limited to the Jak and Daxter Games, the Ratchet and Clank games, Crash Twinsanity and Final Fantasy: Dirge of Cerberus.

The issue happens when using either DX9, DX11 or OGL both on HW and SF mode and using either a Nx resolution from the dropdown or a custom one. I'm certain the issue is limited to the emulation of certain games like the ones mentioned and not something global as it's always happened to me on all the versions I used along the years and only for the same games.

Sample image (internal resolution of 1920x1080):
[Image: yOZhzHq.jpg]

What I'm looking for is a fix to the issue or, at the very least, an explanation to why it happens. Does anyone know anything about this?

Regards,
MetalTxus.
PCSX2: 1.5.0 dev build
GS: GSdx32-AVX2, OGL (Hardware)
> My settings <

OS: Windows 10 x64
CPU: i3-4160 3.6GHz
GPU: GTX 1050 Ti
RAM: 2 x 4GB DDR3 798MHz
Reply

Sponsored links

#2
Upgrade to the latest build here and see if it fixes your issue: https://buildbot.orphis.net/pcsx2/
Reply
#3
(01-02-2018, 06:23 AM)CK1 Wrote: Upgrade to the latest build here and see if it fixes your issue: https://buildbot.orphis.net/pcsx2/

I already downloaded the latest build before the testing, from that same page, so I'm afraid it has nothing to do with that.
PCSX2: 1.5.0 dev build
GS: GSdx32-AVX2, OGL (Hardware)
> My settings <

OS: Windows 10 x64
CPU: i3-4160 3.6GHz
GPU: GTX 1050 Ti
RAM: 2 x 4GB DDR3 798MHz
Reply
#4
(01-02-2018, 07:12 AM)MetalTxus Wrote: I already downloaded the latest build before the testing, from that same page, so I'm afraid it has nothing to do with that.

1.4.0 is not the latest version (that is what you have linked in your signature)... The latest version is the GIT version you can find on the linked page.

This is the latest version: v1.5.0-dev-2242-ge10ac8cbe altiereslima 2017-12-28 06:41:23 Download Portuguese-BR translation update (#2209) Translated new strings and few updates.

https://buildbot.orphis.net/pcsx2/index....indows-x86
Reply
#5
(01-02-2018, 11:31 AM)mstreurman Wrote: 1.4.0 is not the latest version (that is what you have linked in your signature)... The latest version is the GIT version you can find on the linked page.

This is the latest version: v1.5.0-dev-2242-ge10ac8cbe altiereslima 2017-12-28 06:41:23 Download Portuguese-BR translation update (#2209) Translated new strings and few updates.

https://buildbot.orphis.net/pcsx2/index.php?m=dl&rev=v1.5.0-dev-2242-ge10ac8cbe&platform=windows-x86

He just said he downloaded it from the build bot.

That aside, are you using a custom resolution or one of the multipliers? The custom resolution typically pushes GS harder, doesn't look as nice, and can cause upscaling artifacts.
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ RGB Series, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070Ti FTW2 (8 GB)

Oh yeah Red Pandas are cool too.

Reply
#6
(01-02-2018, 11:31 AM)mstreurman Wrote: 1.4.0 is not the latest version (that is what you have linked in your signature)

Yeah, I need to update my signature. I'm using the latest available dev build (v1.5.0-dev-2242-ge10ac8cbe).


(01-02-2018, 04:55 PM)pandubz Wrote: are you using a custom resolution or one of the multipliers?

I tried both, multipliers and custom resolution but no difference was noticeable.
PCSX2: 1.5.0 dev build
GS: GSdx32-AVX2, OGL (Hardware)
> My settings <

OS: Windows 10 x64
CPU: i3-4160 3.6GHz
GPU: GTX 1050 Ti
RAM: 2 x 4GB DDR3 798MHz
Reply
#7
Try this:
1.Set some scaling mode=>hit ok=>restart pcsx2
2.Go to GSdx and see if your settings are still the same(changed)

The usual UAC writing permissions
If I set GSdx.ini as read-only(imitating UAC restrictions),changing the resolution and hitting ok does nothing,the game is still at the same resolution.
Reply
#8
(01-02-2018, 05:44 PM)vsub Wrote: Try this:
1.Set some scaling mode=>hit ok=>restart pcsx2
2.Go to GSdx and see if your settings are still the same(changed)

The usual UAC writing permissions
If I set GSdx.ini as read-only(imitating UAC restrictions),changing the resolution and hitting ok does nothing,the game is still at the same resolution.

I'm an admin user so I shouldn't have permission issues.

The selected settings persist after an emulator restart. I can boot up Jak, for example, and it draws as what appears to be native resolution for whatever reason and then change to Final Fantasy XII, for example, and it draws at the set resolution and then come back to Jak and it will once more draw at low resolution.

I'm certain the issue is limited to the emulation of certain games like the ones mentioned and not something global as it's always happened to me on all the versions I used along the years and only for the same games.
PCSX2: 1.5.0 dev build
GS: GSdx32-AVX2, OGL (Hardware)
> My settings <

OS: Windows 10 x64
CPU: i3-4160 3.6GHz
GPU: GTX 1050 Ti
RAM: 2 x 4GB DDR3 798MHz
Reply
#9
(01-02-2018, 05:54 PM)MetalTxus Wrote: I'm an admin user so I shouldn't have permission issues.

Tell that to microsoft
I also am admin user but I'm sick of those restrictions(every time I have some problem,the solution is almost always related to permisions).

I also encounter this problem long ago but I didn't find what caused it and I don't remember how I fix it.
Did you tried the most basic one...restarting your pc

And btw,I just tried Jak 1 and FF12 and both work fine...when I change the scaling mode,the change is applied
Reply
#10
Same here vsub...I can confirm that when I changed the IR for Jak 1, it did apply the changes. Couldn't test it on FF12 cause I don't own that game. I'm also using the latest GIT build, but I don't recall ever having a problem with it not scaling correctly
Windows 10 64 bit OS
Intel Core i7-6700 3.4 GHz
Geforce GTX 1060 3GB
16 GB DDR4 RAM
Reply




Users browsing this thread: 1 Guest(s)