Invalid: [Bug Report] Cold Winter - Issues with Qt
#1
[Bug Report] Cold Winter [NTSC-U] -SLUS 20845





# PCSX2 version: Nightly 1.7.3465

# PCSX2 options: default

machine: Laptop MSI GL75 Leopard 10SCXR, windows 10, NVIDIA GeForce GTX 1650





Hello guys, i have encountered strange bug where game does not work on Qt, but does on Wx.On Qt game hangs during memory card selection, regardless there is mem card inserted or not (see pic), and regardless renderer (also on software). On Wx you can normally go to main menu in the game.



PCSX2 remains responsive, but after minimizing game only white screen (even after resetting via menu)



GS Dump
mega.nz/file/S2Y2WYaA#MaIx0eHP9EiouNpW9McjIqF18d1E-JIxCy5tzCihfyg
mega.nz/file/juo1BDLL#BkJ3lVV4epjfn41TaRcwYJLXljcsc44cruqs-yoNt2A


my first post here, sorry for mistakes. Thanks for reading!


Attached Files Thumbnail(s)
       

Sponsored links

#2
Is the path to your pcsx2 weird? any funny characters that aren't standard alphanumeric? does moving the Qt version somewhere else like C:\PCSX2 help at all?

Not sure what else to suggest, the emulation is the same, just the memcard path management is different (which should affect all games)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#3
(10-24-2022, 10:36 AM)refraction Wrote: Is the path to your pcsx2 weird? any funny characters that aren't standard alphanumeric? does moving the Qt version somewhere else like C:\PCSX2 help at all?

Not sure what else to suggest, the emulation is the same, just the memcard path management is different (which should affect all games)

Hello, thank you for your response. Actually i have managed to identify the problem. As it looks, the issue comes from OpenGL renderer, all other renderers work fine (previously i switched to software during game start, and it apparently not worked, sorrry for confusion). And on Qt in automatic renderer option it chooses OpenGL, and on Wx it chooses Vulkan (it is designed this way?). thats why I thought problem was elsewhere.

anyway on newest 1.7.3484 bug exists
#4
ah you probably need to make a profile in your nvidia driver for the QT version of PCSX2, I think your problem is the OpenGL driver is defaulting to your onboard IGPU (probably an intel one) and you have a buggy driver.

But this is why automatic defaults to OGL in Qt.

Just for information, I couldn't reproduce it here on my Nvidia card, nor could our intel iGPU guy, but he's on linux.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#5
indeed on that laptop there is beside Geforce also Intel graphics. And also you are right that after creating profile for PCSX in Nvidia drivers, emulator choose Vulkan.
unfortunately updating drivers didnt change the thing, but your solution is more than sufficient.
thanks for looking into that matter!
#6
No problem Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#7
Thank you for your report.
This bug report has now been marked as Invalid since it either was not reproducible, not a valid bug or otherwise unacceptable for fixing.

This thread will now be closed and moved in the Invalid/rejected/duplicate bug reports subforum.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)