Invalid: [Bugreport] savestate corruption
i've been using different emulators for a while, and sometimes i've noticed they did not create savestates when prompted. That's why i've developed a habit of pressing "save" twice.
0.9.8 and current svn sometimes corrupt savestates in this situation (do not make a new savestate and ruin old savestate on selected "slot" - that is why it is a problem to me)[/code].

[wx] can't find central directory in zip
Savestate is corrupt or incomplete!
Path: C:\pcsx2-0.9.8-r4600-binaries\sstates\SLUS-20370 (0F6B6315).00.p2s
(pxActionEvent) Savestate file does not contain 'PCSX2 Savestate'(VM_UnzipFromDisk)

On previous versions of pcsx2 i did not have problem with that (0.9.6-0.9.7 and svns).
I don't know in what svn it broke, cause i did not use pcsx2 for a while.
To make a proper bugreport i did clean install and test PCsx2 0.9.8 stable without any changes of settings. (Just bios select)

to test it hit:
"F1, F1, F3"; "F1, F1, F3" ...
usually happens within 3 tries.
Phenom II X4 940 3 Ghz / 8 gb RAM 800 / Geforce GTX 460 / win7 64

Sponsored links

Enabling backup will help, but you have to make sure that you aren't exitting out of PCSX2 too soon. The savestate recording is being done on a seperate thread since the later betas of 0.9.7 and later, meaning it doesn't pause the emu at all to write it. So if you close the emulator too soon after you save, it won't have finished actually writing it leaving you with a corrupt savestate.

(edit) Or in the case of your example, you're trying to load the save most likely before it's finished being written.
[Image: 2748844.png]
0.9.8 has a bug where the file handle is not closed after performing a write operation.
Squall Leonhart, is it fixed in current svn already?

Koji, i dont think so..first time i encounter it - i tried to load savestate after a gameover, so emu did have a lot of time to write savestate. There was something wrong with "double saving".

I dont remember the option "backup", gonna try to find it..
Phenom II X4 940 3 Ghz / 8 gb RAM 800 / Geforce GTX 460 / win7 64
I couldn't reproduce the file handle bug yet so it's not the same for everyone.
Try not to send too many savestate actions at once, we know this isn't stable.
it might be write caching screwing up on some hdd's.
I couldn't reproduce this bug, I did get an error after spamming F1 in 0.9.8 & 1.2.1 stable versions, but even that has been resolved in later git versions. I'm pretty sure this has been solved or otherwise not an issue, but I don't own Kingdom Hearts NTSC-U (the game, 0F6B6315, mentioned in the Code) to rule it out completely.
Probably some issues on the OP side since rama couldn't also reproduce the issue, I think it's safe to put it into invalid/resolved if it couldn't be reproduced.
Thank you for your report.
This bug report has now been marked as Invalid since it either was not reproducible, not a valid bug or otherwise unacceptable for fixing.

This thread will now be closed and moved in the Invalid/rejected/duplicate bug reports subforum.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]

Users browsing this thread: 1 Guest(s)