Invalid: "FFX-2 chapter 2 bug" PLEASE HELP
hello everyone

I am using PCX2 version 1.0.0 and I have downloaded FFX-2 from this link:

everything is working fine and all but when I hit chapter 2 there seems to be a bug;
after I finish seeing what the sphere holds and everybody wants Yuna to dance I go to the Cabin and I push all the singers or w/e to the elevator.

According to all guides and walkthroughs, After I push the singers to the lift a cut scene should start. but in my case nothing happens at all. (see attachment)

ps: all 3 of them are inside the lift even the small guy, I tried different order and the same happens

I tried everything and nothing works.

I Played FFX and Dirge of cerebrus and they both worked great.

anybody knows anything about that?

is the problem in the download file? (iso)
if yes, where can I downloaded a better version without bugs?

Thank you very much

Sponsored links

Quote:I have downloaded FFX-2 from this link:

Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Thank you for your report.
This bug report has now been marked as Invalid since it either was not reproducible, not a valid bug or otherwise unacceptable for fixing.

This thread will now be closed and moved in the Invalid/rejected/duplicate bug reports subforum.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

Users browsing this thread: 1 Guest(s)