Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Invalid Klonoa 2 + SPU clash .... round XXX >_< .. ding ding...
#1
HAVE a beef with the spu plugin >_< ..again...

Well, ingame klonoa i noticed sound effect is missing from the game using the spuX2 regardless of the (xaudio and dsound) setting .... but (and tis is important part) no crashes there .... not yet ....

Then i tried ZeroGee sound plugin Rxxxx (and do pay attention on the rXXX part) to try and get the missing SFX back !

And with some tweaking in the plugin settings i got full sound support back ingame. atleast i hear the sfx sound again ...

Now, the rxxxx plug did crashed twice in a row in an 2 - 5 minute window !!

UNTILL.. i chose the same plugin but whitout the rXXXX notation...
when i did chose the latter zerog spu from the plug list (whitout the rXXXX notation) pcsx2 didn't crashed anymore .... ever since !!

now, i did ask before what (if there is any difference) ... what could be the difference between lets call it plug A and plug A rXXXX


so here you have plug A beeing the same as plug A rXXXX but without the Rxxxx !!!

could it be that plug A (whitout the rxxxx) is the stable version and the other similar one (appart from the rXXXX) is a beta/TEST version !!!..

same question for other "duplicate" pluggins !!

Now, klonoA 2 is just an good HIGH rES LOOKING GAME Blush ... no complaints there ... yet.. Laugh

Important to report is, that i don't have had any graphics glitches in game so far....

NOW the sound i have fixed aswell, but i do wonder why 1 of 2 very same plugins sort of speak did crashed like time and time again !!!

cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1

Sponsored links

#2
The non rxxx copy is theoretically the last rxxx you installed, but at this point I have no idea about the changes you might have made in the plugins directory.

PS: I mean the last revision you "installed", not necessarily the latest revision.
Imagination is where we are truly real
#3
(12-19-2012, 10:38 PM)nosisab Ken Keleh Wrote: The non rxxx copy is theoretically the last rxxx you installed, but at this point I have no idea about the changes you might have made in the plugins directory.

PS: I mean the last revision you "installed", not necessarily the latest revision.

Iam still on pcsx2 r5452 and r5460 at the same time ...

Well, some plugins have r5460 while pcsx2 build is 5452 Wacko ...
Not sure what to make of that ...

But anyway, i haven't made any changes to plugins myself..

I just keep and use the plugins that came with each SVN build ...

And thats just it...

The SVN "r5460" build (though the pcsx2 in that DL is still 5452 regardless!!) came with 2 very same zeros rXXXX SpU plugins... again only difference is the rXXX notation !

And thats just the interesting part, if those duplicate plugs i.e (spu-x VS spu-x-rXXX, GSDX-SSE2 VS GSDX-SSE2-rXXX) are infact the EXACT same 2 SPU plugins that each build you DL here are packed with !

Why does pcsX2 crashes only using ZeroGS-rXXXX spu and not zeroGS for in this case !!

Tis quite an mistery alright with that audio part in pcsx2 !!!

Cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
#4
P.S: just took an look at the latest SVN builds... and i noticed allot of changes at the spux level Rolleyes .


Update: aarrgh.... same thing happend .... on Zero SPU-X non-rXXXX compliance giggles...
Almost instant crash ... and very quick too !! While on SPU-X 2.0 r5478 (latest spu-X from SVN build 5481) i have no crash, but also NO decent SFX sound !!! background music however does work !!!


oh well...

Update 2: ah... pcsx2 crash NO MORE I tell ya..Biggrin

Just need to uncheck alll boxed options in SPU zero plugin not only to avoid crashes but also to have clean and crisp sound Laugh

Default settings in Zero SPU ALWAY's and i do MEAN ALWAY's distort the sound.. scratches and whatnot realy screwed Blink

So, disable Time scaling and real time mode solved al my problems Biggrin

Now... UP TO THE NEXT LEVEL of awareness ... Ninja
cherriepoppers
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
#5
Seriously, if you're gonna file a bug report, don't do it like a blog post or something. Most your information is controversial, not easily understandable and/or plain wrong.
Also I think we have confirmed it's just you getting the weird crashes with SPU2-X, meaning your system has issues (no, that is not debate-able, if the issue was the plugin we would have hundreds of reports instead of just yours)

Quote:could it be that plug A (whitout the rxxxx) is the stable version and the other similar one (appart from the rXXXX) is a beta/TEST version !!!..

No it is the exact same file. If you get different behavior with these 2, it either means your system is problematic randomizing the output or you just think it sounds differently (placebo)
[Image: newsig.jpg]
#6
(12-20-2012, 02:48 PM)Bositman Wrote: Also I think we have confirmed it's just you getting the weird crashes with SPU2-X, meaning your system has issues (no, that is not debate-able, if the issue was the plugin we would have hundreds of reports instead of just yours)

Well i can tell ya that my system works just great on other games and i have had NO SPU2-x Crashes on those games ..

For instance, currently iam playing through Final Fantasy Zodiac Job system.. and i have recorded 35+ish gameplay hours already..

And not ONCE, i REPEAT ... NOT ONCE i have had an SPU-X2 failure/crash.. during that time !!

Now i dont know about you, but that pretty much proves that my system is not entirely to blame for .... else i woud have had crashes in any game... logic dictates Closedeyes !!

anyway, i take back what i said earlier about Zero-Spu2 plug... it does crash at one particular level in klonoa2... regardless of what system /pcsx2 setting (drivers!) Glare

Also, my info is controversial you say?

Rest asure, every bit info i provided did infact happend to me ..
What woud i gain by lying about it !!!

In that regard, you should be more gratefull to someone who puts time and efforts troubleshooting pcsx2 progress !!

So currently unable to proceed/continue with the game due to crash all the time..

So KLONOA 2 status = INGAME
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
#7
(12-20-2012, 03:51 PM)Metagondria Wrote: Well i can tell ya that my system works just great on other games and i have had NO SPU2-x Crashes on those games ..

For instance, currently iam playing through Final Fantasy Zodiac Job system.. and i have recorded 35+ish gameplay hours already..

And not ONCE, i REPEAT ... NOT ONCE i have had an SPU-X2 failure/crash.. during that time !!

Now i dont know about you, but that pretty much proves that my system is not entirely to blame for .... else i woud have had crashes in any game... logic dictates Closedeyes !!

anyway, i take back what i said earlier about Zero-Spu2 plug... it does crash at one particular level in klonoa2... regardless of what system /pcsx2 setting (drivers!) Glare

So currently unable to proceed/continue with the game due to crash all the time..

So KLONOA 2 status = INGAME

My advice is, delete completely PCSX2 folder (least savegames, memcards and BIOS, of course). Actually sstate "may" be the reason for the troubles... well...

And install it again. Be aware the non numbered revision is the same numbered revision file for that build. So if you install a previous version over an existent newer, you'll have three files there, the non numbered will be the same file as that you installed last, overwriting whatever was there before.

I cant say anything about that particular game for I don't have it. What reminds me the games local store announced will be putting old console games at huge discount for the Christmas season, may be a good opportunity to buy some (Sony must thanks PCSX2 for I would never ever cogitate buying more games for the console otherwise Smile ).
Imagination is where we are truly real
#8
(12-20-2012, 03:59 PM)nosisab Ken Keleh Wrote: My advice is, delete completely PCSX2 folder (least savegames, memcards and BIOS, of course). Actually sstate "may" be the reason for the troubles... well...

And install it again. Be aware the non numbered revision is the same numbered revision file for that build. So if you install a previous version over an existent newer, you'll have three files there, the non numbered will be the same file as that you installed last, overwriting whatever was there before.

I cant say anything about that particular game for I don't have it. What reminds me the games local store announced will be putting old console games at huge discount for the Christmas season, may be a good opportunity to buy some (Sony must thanks PCSX2 for I would never ever cogitate buying more games for the console otherwise Smile ).

Well, i do use an seperate clean install (sort of speak) to troubleshoot game issues...

You see, i just use and extract an portable version of the pcsX2 1.1 to a different location right..

Wheiter its installed or unzipped probebly won't make any difference to games is it now... Unsure

i'd be surprised that using an portable versions woud break game compatibility !!

But, i'll try that anyway... iam eager to find out if that woud be the root of my spu problems !!

Somehow i seriously doubt it!!

Also, i never ever use Save States (0,1,2..) build in feature..
I always use Memcard to save...

i know from the epsx day's it can cause problems Glare

Last, i don't think i ever will buy another ps2 console .. have had bad experience with the latest released slim models...

Several of my perfect kept games did not read well on the latest slim line models !!

i suspect they have lowered the pot callibration of the lasers eye so much that it barely can read the data
nowdays !!!

Update Unsure :
Well, i was as curious to see what woud happen if i used an installed version of pcsx2...
And this is what happend when i testrun klonoa2...Rolleyes

Faulting application name: pcsx2-r5350.exe, version: 0.0.0.0, time stamp: 0x50191438


But the GOOD part about that errr or. , tis NO nonsense SPU crash up ↑ there Happy

Furthermore, i had to reset the game many times due to BLACK SCREENS all of an sudden !

Also black screens on the portable version now too i always have used whit "less" "issues/problems" ... !!

which leads me to think that the dxweb setup that came with the pcsx2 instlal might have altered /changed some DX files that most probebly might causing this Glare !!

Now, i can dig and search for that to fix it Glare !!!

Although, a system restore can do wonders aswekk Laugh and is much faster too .

Update 2 Unsure : well folks iam baffled... did a system restore because of that suspicious dxweb + blackscreen combo thing !!

And all of a sudden Klonoa2 did NOT crash anymore....
I even got past that particular scene now , the part at which pcsx2 woud crash time and time again!!

But important to mention is , i did start a new game = new game save !!!!

Is it possible gamesaves act differently with each different rXXX plugin / rXXX pcsx2 !!

One time i had to restart BO2 all over again aswell, because kain fell down in an deep black hole .. the hole supposed to be the exit from the dungeon !!

And indeed, an new game did solved it... morale of the story ... gamesave do corrupt the gameplay progression !!


oh welll...


Thanks for your helpfull thoughts on this matter,


cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
#9
(12-20-2012, 04:17 PM)Metagondria Wrote: Well, i do use an seperate clean install (sort of speak) to troubleshoot game issues...

You see, i just use and extract an portable version of the pcsX2 1.1 to a different location right..

Wheiter its installed or unzipped probebly won't make any difference to games is it now... Unsure

i'd be surprised that using an portable versions woud break game compatibility !!

But, i'll try that anyway... iam eager to find out if that woud be the root of my spu problems !!

Somehow i seriously doubt it!!

Also, i never ever use Save States (0,1,2..) build in feature..
I always use Memcard to save...

i know from the epsx day's it can cause problems Glare

Last, i don't think i ever will buy another ps2 console .. have had bad experience with the latest released slim models...

Several of my perfect kept games did not read well on the latest slim line models !!

i suspect they have lowered the pot callibration of the lasers eye so much that it barely can read the data
nowdays !!!

Update Unsure :
Well, i was as curious to see what woud happen if i used an installed version of pcsx2...
And this is what happend when i testrun klonoa2...Rolleyes

Faulting application name: pcsx2-r5350.exe, version: 0.0.0.0, time stamp: 0x50191438


But the GOOD part about that errr or. , tis NO nonsense SPU crash up ↑ there Happy

Furthermore, i had to reset the game many times due to BLACK SCREENS all of an sudden !

Also black screens on the portable version now too i always have used whit "less" "issues/problems" ... !!

which leads me to think that the dxweb setup that came with the pcsx2 instlal might have altered /changed some DX files that most probebly might causing this Glare !!

Now, i can dig and search for that to fix it Glare !!!

Although, a system restore can do wonders aswekk Laugh and is much faster too .



Thanks for your helpfull thoughts on this matter,


cherriepoppers,

The dxwebsetup is this the name says, it takes the latest DirectX version from MS directly. No, it didn't break anything there unless something is already broken with the Windows there.

Is highly advised you subject your PC to online scan for virus and malwares. Keep an eye on the System log (at the Event viewer). All your reports seems to point you have something wrong in there.

Malware can get into the machine of the most cautious people... some can get into before they are known, for that reason is advisable to run complete scan periodically and don't rely only on the realtime protection.

I believe you read my post in another your threads where is reported I found a nasty adware on my machine which was causing CPU spikes and crazy disc spinoffs. Since I hunt it down the system became responsible once again and I had no crashes or slowdowns anymore.
Imagination is where we are truly real
#10
(12-20-2012, 06:30 PM)nosisab Ken Keleh Wrote: The dxwebsetup is this the name says, it takes the latest DirectX version from MS directly. No, it didn't break anything there unless something is already broken with the Windows there.

Is highly advised you subject your PC to online scan for virus and malwares. Keep an eye on the System log (at the Event viewer). All your reports seems to point you have something wrong in there.

Malware can get into the machine of the most cautious people... some can get into before they are known, for that reason is advisable to run complete scan periodically and don't rely only on the realtime protection.

I believe you read my post in another your threads where is reported I found a nasty adware on my machine which was causing CPU spikes and crazy disc spinoffs. Since I hunt it down the system became responsible once again and I had no crashes or slowdowns anymore.


Well... according to Avast, Mbytes, Comodo.. and what not my pc has an clean bill of health !

About, that Dx update... however..

I have read at M$ HQ that it is not alway's wise to update the DX files on a system ...

That that might harm more than cures !!

And, indeed i have read several posts from people that had problems with their pc games after updating DX content and broke their system...instead of improving it...

Not only that, but i have noticed that an particular error showed in the pcsx2 logs is NOW GONE !!

Couldn't that have beeen the issue i have had ..?



cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 [email protected] stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1




Users browsing this thread: 1 Guest(s)