Is Final Fantasy X International broken on latest snapshot ?

First of all, I know this topic would fit better into the Bug report category, but since I'm new to PCSX2 iI could also have made a mistake, so I'd rather not harass developers with a useless bug report for now.

So, I wanted to play Final Fantasy X International (Japanese version, MD5 50161B879A829583B69C0E93B6D987E9 ) on one of the latest git snapshot (1.2.1-586-gf287754). After configuring PCSX2, the game doesn't boot (black screen). I've tried to disable "Automatic gamefixes", without luck.

On PCSX 1.2.1 stable release, the game runs fine (well, at least it boots to main menu) with the exact same configuration as the snapshot version.

I didn't touch the plugins configuration except for the pad (I'm using Pokopom pad instead of Lilypad), so the test were done with GDSx SSE2, Pokopom pad, SPU2-X and I don't think the other one matters).

On a side note, FFX NTSC (Hash 57998B60010B7583C423D5B2142AD1A3) works fine on both snapshot and stable release.

I'm running the game from an ISO file, and my computer has the following specifications: Intel Core Q6600 non-overclocked, GTX 560Ti, 8GB RAM on Windows 8.1.

So I'd like to know if anyone can test FFX International on latest git snapshot so I can fill a proper bug report if the issue is confirmed.


Sponsored links

As would any mod will post:

Quote:In order to help you further with your problem, please make sure the following are all provided.

- Your hardware specs - CPU, Graphics Card, Memory, Operating System.
- The version of PCSX2 you are using.
- Any non default settings you are using.
- What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Insert Witty Sig Here.]
Versions and non default settings were specified. I'm running the game from an ISO file.

Hardware specs are Intel Core Q6600 non-overclocked, GTX 560Ti, 8GB RAM on Windows 8.1.

(Added these informations to main post for more clarity)
What did the log say?
[Insert Witty Sig Here.]
(09-16-2014, 01:29 PM)KeyToTruth12 Wrote: What did the log say?

Here's the log:

PCSX2 1.3.0-20140916112210  - compiled on Sep 16 2014
Savestate version: 0x9a0a0000

Host Machine Init:
    Operating System =  Microsoft  (build 9200), 64-bit
    Physical RAM     =  8191 MB
    CPU name         =  Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
    Vendor/Model     =  GenuineIntel (stepping 0B)
    CPU speed        =  2.404 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 0000e3bd
    x86EFlags        =  20100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Jeux\PCSX2-2\plugins\GSdx32-SSE2.dll
    Binding  PAD: C:\Jeux\PCSX2-2\plugins\padPokopom.dll
Windows 6.2.9200
    Binding SPU2: C:\Jeux\PCSX2-2\plugins\SPU2-X.dll
    Binding CDVD: C:\Jeux\PCSX2-2\plugins\cdvdGigaherz.dll
    Binding  USB: C:\Jeux\PCSX2-2\plugins\USBnull.dll
    Binding   FW: C:\Jeux\PCSX2-2\plugins\FWnull.dll
    Binding DEV9: C:\Jeux\PCSX2-2\plugins\DEV9ghzdrk.dll
Plugins loaded successfully.

(GameDB) 9653 games on record (loaded in 418ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
Windows 6.2.9200
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
NVIDIA GeForce GTX 560 Ti   (
    Opening CDVD
isoFile open ok: C:\Games\FFX-International.iso
    Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2210704 sectors)
    Opening USB
* SPU2-X: PortAudio error: Invalid device
    Opening FW
    Opening DEV9
Failed to GetNetAdapter()
McdSlot 0: C:\Jeux\PCSX2-2\memcards\Mcd001.ps2
McdSlot 1: C:\Jeux\PCSX2-2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLPS_250.88;1) Game CRC = 0x658597E2, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPS_250.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(GameDB) Enabled Gamefix: IpuWaitHack
EE/iR5900-32 Recompiler Reset

From there the screen stays black.
Try setting automatic gamefix off.
[Insert Witty Sig Here.]
(09-16-2014, 01:49 PM)KeyToTruth12 Wrote: Try setting automatic gamefix off.

I've already tried that, sorry it was a bit unclear in the first post. It still doesn't work.
Did you tried fast boot or full boot?
[Insert Witty Sig Here.]
(09-16-2014, 01:59 PM)KeyToTruth12 Wrote: Did you tried fast boot or full boot?

Both (the log one was fast boot though)
Then I got nothing :/ sorry. Just play from the stable version. It's called stable for a reason Tongue2
[Insert Witty Sig Here.]

Users browsing this thread: 1 Guest(s)