Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is there really nothing that can be done about motion blur?
#11
From looking at that thread, Disgaea the game itself seems to have added the blurring motion. FFX the blurring only happens when the character forces the background to move as in if the character only moves a little bit so that the background does not have to change, the blurring does not happen, but if the background has to move to show the new area, it blurs. I think FFX might have more to do with the same blurring that happens when movies scenes span a wide area(I'm guessing that is the same as motion blur). I tired the interleave/hardware/software settings but the only thing that stops the blur is speeding up the game with tab or f4.

Sponsored links

#12
Here's what intrigues me: if it's an interlacing thing like avih explained, then more (most?) PS2 games should exhibit the same massive amount of ghosting that these Atlus games do.

That's why I'm convinced it's some kind of setting particular to these games, and I'm hoping it can be disabled somehow, maybe with a .pnach patch.
#13
(02-27-2014, 02:44 PM)Draconic Seed Wrote: Here's what intrigues me: if it's an interlacing thing like avih explained, then more (most?) PS2 games should exhibit the same massive amount of ghosting that these Atlus games do.

Not true.

For most games GSdx can produce native progressive image (not interlaced and doesn't require deinterlacing even if the game is not set to 480p display). E.g. GOW, ICO and many others. For those games, it doesn't matter if the in-game options are set to output progressive or "normal" (interlaced) - GSdx can and does output progressive regardless.

But for some games, especially games with "postprocessing" effects (which confusingly sometimes include intentional blur), GSdx can't produce native progressive image, so those games have to be deinterlaced (which uses the Blend method by default - which creates blur during movements - but you can manually choose different deinterlace like bob which doesn't blur). E.g. Gran Turismo games (if the output isn't set in-game to 480p).

If you want to know if GSdx can output native progressive image for a specific game, set deinterlace mode to "None", and if it has a comb effect (horizontal lines) then it needs deinterlacing, otherwise, it's properly progressive and doesn't require deinterlacing (which means that if there's blur then it's intentional by the game and not a side effect of deinterlacing).


Visit this page to read a bit about (de)interlacing: http://www.100fps.com/

The first 3 images show interlaced image which was not deinterlaced. If you set GSdx deinterlace to "None" and the image looks like any of the first 3 images, then it needs deinterlacing.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
#14
Something strange happened...I pressed F4 and the ghosting disappeared completely, however...the fps jumped to 140. :/

Does anybody know WHY you only get a normal looking game when you disable frame limit?

This is hella frustrating.
#15
All you would need is a half-speed cheat for that game. Like what was done to Kingdom Hearts 2. I followed the same instructions and got FFX to get rid of all the ghosting and motion blur caused by movement by setting the base framerate to 200 and audio syncing mode to async mix. All I need now is a half-speed cheat like the one for Kingdom Hearts 2.
#16
@ maguss

Yeah, that would probably work. The problem is finding the memory address that controls the game speed, since in that thread the guy mentioned he found the data for Kingdom Hearts entirely by luck...

That's not very encouraging, but at least we know a solution is possible. 60 fps is amazing and I don't understand why this isn't the norm in modern games yet.
#17
Yeah plus no one's really working on it because it's not a necessity and more of a aesthetic thing though I agree games look much more fluid and clean without the motion blur.
#18
I just signed up to hopefully save someone a headache (literally).
I get mad motion sickness with this game, so I invested a load of time into trying to find the best possible plugin. I've finally found a plugin that completely removes the blurring!

Here's the GPU plugin:
http://www40.zippyshare.com/v/92424870/file.html

(It's one custom edited for Valkyrie Profile 2)

Edit: Make sure you have the plugin set to GDSX9 and not using DX11, or you will get weird graphical errors.
#19
It doesnt worked for me, sadly.
Reading internet it seems thats its a big problem for pcsx2, I wasnt seeing it too much on my previous 60hz but now im on 144hz... lot of games are near unplayable... some are just playable.
Its so bad for the future.
I think I'll take an old 60hz screen just to test, lol, maybe it will cut all my 144hz/gsync advantages so I will plug it only for pcsx2.
i5 [email protected],9ghz / Gtx980 Msi Gaming / 2x SSD Samsung 840pro 256gb / Acer Predator 24" G-sync
Corsair K95 RGB / Logitech G502 Proteus Core / Bose Companion 2 Serie III
Old JRPG fan, experienced mmo player, PC hardware expert
#20
Oh wow...I can't belive I found my old thread still alive after a year.

Asator_MK, I tested your plugin and it's fantastic! It doesn't completely remove the blur but it reduces it A LOT, to the point that if I combine it with the IFC setting in my TV, it's pretty much like playing a 60 fps game. Awesome! So I just wanted to say a big THANK YOU, my friend. Smile

I think this proves that the motion blur issue can be fixed or at least improved with plugins as I hoped. I know this is not a priority for pcsx2/gsdx coders, but they certainly should look more into it.

By the way, this plugin also works for the Digital Devil Saga games, they look amazing with it. Persona players should give it a shot, maybe it works for those games too.




Users browsing this thread: 1 Guest(s)