Is this a game or an image issue?
So I wanted to play Gran Turismo 3 A-Spec PAL version (SCES50294) on PCSX2 1.1 r5730.

The game loaded just fine, ingame menus were all displayed and also the garage was fully accessible.

However when I tried to drive on a track my whole system moreless froze (I couldn't even move my mouse pointer anymore). It seemed like the system was under heavy load but I've never seen something like this to this extent.
The only thing I could do was force a reboot the old fashioned way, by hitting the reset button.

I know that the PAL version of the game is marked as "Ingame" in the compatiblility list but since there are no further details posted to what the problem is I wonder if this is it?
I would have imagined that the emulator would simply crash or freeze but not that my whole system would freeze, I didn't even know this could happen nowadays because of a single program.

The other thing that might be relevant is that the disk I got the image from was in a rather bad shape already, it even took a whole day for UltraIso to burn the image (but at least I got no error).

So I wonder what could have caused this? Or if anybody can tell me some further details about what the problem with the PAL version of GT3 is?

Sponsored links

Bad image can't case that.
There are some games that have problems(excessive ram usage and so on)and something like that can happen.

I don't have the game but it's normal for that game to require a lot more resources while playing some track rather than in's the same thing with GT4 too(it requires much more power from your pc while playing some track)
how are your specs?

I think if you have an excessive cpu-load combined with a high ram-usage you can still kill your system. I think if you have a dual-core this is easier to achieve than for a quad-core.

You can decrease the process-priority of pcsx2 and use an already opened taskmanager. If you pc still is completely freezing I would rather think of a hardware/driver issue.
Quote:There are some games that have problems(excessive ram usage and so on)and something like that can happen.
Yeah but normally the OS would warn me that there is heavy RAM usage or something like that. And even under heavy load I would normally be able to use my mouse pointer or at least Strg+Alt+Entf my way out of the situation (which showed up minutes after I pressed it but the system still wouldn't really react to any input).

System specs:
CPU: Intel Core i5-3570k @3.4 GHz
GPU: Nvidia GeForce GTX 670
RAM: 4GB (normally 8GB but I had to remove one module)
MB: Asus P8Z77-V
OS: Windows 7 Prof. 64 bit

All latest drivers are installed and are working properly.

At a later point while I was browsing through the game menus it also froze the same way when I called the menu "Game operations" (or something like that) in the main menu which essentially just shows the save files on your memory cards.
The way it froze there was that it first loaded and displayed a couple of save files but then suddenly everything got extremely slow up to the point where I couldn't really do anything anymore.

So that makes me think that its neither a hardware nor a driver issue.
With this system I would never expect something like this.

Why have you removed one RAM-block?
I think its an hardware/driver-problem.

Maybe you can type 'eventvwr' into the start menu and look into 'windows protocol'/'system'. on the right side you can 'filter current protocol' and select everything except for 'information'. Now count number of red signs. If your system is perfectly set you get nothing. Yellow marks can appear. Check now for the last time your emulator crashed. Probably there will be a red mark like 'unexpected shutdown' or something like that. Look into the entries directly before that entry. Maybe you have luck and windows protocoled the errors.

Nevertheless look into the red marks. What is written their that is not a network-problem? Like this I always find driver-issues or bad hardware.
I removed it because it caused programs to crash and BSOD's (but nothing like this). I thoroughly checked the modules with memtest and that specific module had errors.
However before you jump to any conclusions I also ran memtest a couple of times for the other module as well (I did them seperately on the same slot on the MB, even recently but I'll do it again later today) and there were no errors whatsoever.

Since I removed the module the system ran fine again, no program crashes or BSOD's.

And no there were no errors reported in the Windows logs besides the unexpected shutdown and some network related errors.

So yeah, once again I'd like to know what the compatibility issue of the GT3 PAL version with PCSX2 is. If its a similar or even the same problem then I'd really like to know further details about it from a programmers point of view.
I dont know about GT3 but GT4 uses huge amounts of RAM/VRAM at the start of the race (after the loading screen) because of the motion-blur effects.
They can easily take over 4GB with x3 or even x2 Scaling. If you removed 1 RAM module you also lostthe Dual Channel Mode and that makes your RAM 50% slower.
That may be the cause for your freezes.

Try using Native resolution in GSDX and "Allow 8-Bit Textures" On/Off (may be faster or slower) and see if it gets better.
(11-14-2013, 03:42 PM)Grove4L Wrote: I dont know about GT3 but GT4 uses huge amounts of RAM/VRAM at the start of the race (after the loading screen) because of the motion-blur effects.
As I said, it even froze when I tried to call a simple menu which I seriously doubt needs any greater processing power (compared to a fully rendered 3D scene).

And even if the race takes up a lot of processing power, the emulator would get laggy at best, not completely freeze the system from one second to the next.

Not to mention that a 32-bit application can only occupy up to 2GB of RAM so it doesn't really matter if I have 4GB or 8GB installed (maybe a little performance improvement but thats it).

I just would like to hear from someone who has tested the GT3 PAL version if there are problems with the latest emulator revision since its the only GT3 version in the compatibility list that is marked as "Ingame" with no further details included. And if yes what these problems are (similar to my problem or completely different).

Users browsing this thread: 1 Guest(s)