Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues running PCSX2 in fedora 27
#11
(12-04-2017, 12:53 PM)gregory Wrote: There are multiple ways to compile GSdx
* no optimization (SSE2)
* multiple binary with different optimization (SSE2/SSE4/AVX2)
* optimization based on the build machine

It feels like a driver issue. But I don't know what version is compiled on Fedora neither if they did properly the transition from SDL1 to SDL2.

I'll have to get on IRC and ask around.
Reply

Sponsored links

#12
(12-04-2017, 12:53 PM)gregory Wrote: There are multiple ways to compile GSdx
* no optimization (SSE2)
* multiple binary with different optimization (SSE2/SSE4/AVX2)
* optimization based on the build machine

It feels like a driver issue. But I don't know what version is compiled on Fedora neither if they did properly the transition from SDL1 to SDL2.

looks like on F27 they are on SDL2.
Reply
#13
(12-04-2017, 12:53 PM)gregory Wrote: But I don't know what version is compiled on Fedora neither if they did properly the transition from SDL1 to SDL2.

wxGTK3 is compiled against SDL2 (in Fedora 27 on release, through updates to F26 and even F25).
Commit: https://src.fedoraproject.org/rpms/wxGTK...nch=master
Reply
#14
ok. To be honest, I'm not sure if any issue remain in this thread.

Anyway, it would be nice to check that both onepad/spu2x are compiled with SDL2 ? Ensure they use a recent 1.5-git version instead of the official (and quite old) 1.4 release.
Reply
#15
(12-18-2017, 05:42 PM)gregory Wrote: ok. To be honest, I'm not sure if any issue remain in this thread.

Anyway, it would be nice to check that both onepad/spu2x are compiled with SDL2 ? Ensure they use a recent 1.5-git version instead of the official (and quite old) 1.4 release.

I git cloned the latest from master and that is where I was trying to build from when I ran into this issue. Then I ran the commands explained in the wiki with cmake. Anything else I should look into>
Reply
#16
What is/are your issue(s) ? You post several thing.
Reply
#17
I think I have same problem after upgrade from F26 to F27. I read the topic and don't understand what should I do. My processor is Celeron N2830.


Code:
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
Loading language translation databases for 'Russian' [ru_RU]
Command line parsing...
Command line parsed!
PCSX2 1.4.0-0- compiled on Oct  8 2017
Savestate version: 0x9a0b0000

Host Machine Init:
    Operating System =  Linux 4.14.13-300.fc27.x86_64 x86_64
    Physical RAM     =  3834 MB
    CPU name         =  Intel(R) Celeron(R) CPU  N2830  @ 2.16GHz
    Vendor/Model     =  GenuineIntel (stepping 08)
    CPU speed        =  2.164 ghz (2 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 41d8e3bf
    x86EFlags        =  28100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...
Illegal instruction (core dumped)


Code:
# find /usr/lib32 -iname "libgsdx*"
find: ‘/usr/lib32’: Нет такого файла или каталога (dir dont exist)
# find /usr/lib -iname "libgsdx*"
/usr/lib/pcsx2/libGSdx-1.0.0.so
Reply
#18
by changelog I changed this :

* Sun Oct 08 2017 Sérgio Basto <[email protected]> - 1.4-5
- Rebuild for soundtouch 2.0.0
- Just enable compat-wxGTK3-gtk2, pcsx2 fails to detect wxGTK3 therefore SDL2 also is disabled, intructions on https://github.com/PCSX2/pcsx2/wiki/Installing-on-Linux
- Enable GLSL_API and AVX
- Fix Perl builroot changes.

Fedora have SDL1 and SDL2 we just need choose one
Reply
#19
You can't choose SDL. If wx is built with SDL1 support, you should build PCSX2 with SDL1. If wx is built with SDL2 support, you should build PCSX2 with SDL2.
Reply




Users browsing this thread: 1 Guest(s)