Its time for another FFX Black Screen with Sound!
Hi there, been going through the forums and Google for 3 hours plus, now. Seems the gremlins are running amok!

So, after it being literally nine years since I played Final Fantasy X, I decided to get back into it on PCSX2. So, things are going smoothly, then I get a little freeze in one of the cinematics (the scene of the island that was destroyed by Sin, with the floating Blitzball...ball in the debris.

Came to the forums, got it fixed.

Now, heres the interesting part, I'm about 17 hours further into the game without a single hitch, when all of a sudden, when Tidus and Rikku are wandering through the desert, trying to find the Al Behd "home" there, to find Yuna, I go to proceed to the next enviroment and black screen... with the soundtrack still running. I reload my savestate, and try the other exit on that same map, and same effect.

I noticed in the debug menu that this would pop up when I tried to enter that twilight zone.

Quote:Loading savestate from slot 0...
filename: D:\Program Files\PCSX2 0.9.8\sstates\SCES-50490 (A39517AB).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(GameDB) Enabled Gamefix: IpuWaitHack
(EE pc:0017B520) TLB Miss, addr=0x60532990 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x605329d0 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x605329d8 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x605329d2 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x605329d4 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a00 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329e0 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329e4 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329e8 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329ec [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329f0 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329f4 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329f8 [load]
(EE pc:0017AB18) TLB Miss, addr=0x605329fc [load]
(EE pc:0017AE50) TLB Miss, addr=0x60532a04 [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a08 [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a0a [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a0c [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a0e [load]
(EE pc:0017B5AC) TLB Miss, addr=0x60532994 [load]
(EE pc:0017B520) TLB Miss, addr=0x605329d0 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a10 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a18 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a12 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a14 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a40 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a20 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a24 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a28 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a2c [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a30 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a34 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a38 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a3c [load]
(EE pc:0017AE50) TLB Miss, addr=0x60532a44 [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a48 [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a4a [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a4c [load]
(EE pc:0017AE68) TLB Miss, addr=0x60532a4e [load]
(EE pc:0017B5AC) TLB Miss, addr=0x605329d4 [load]
(EE pc:0017B520) TLB Miss, addr=0x60532a10 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a50 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a58 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a52 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a54 [load]
(EE pc:0017ADF8) TLB Miss, addr=0x60532a80 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a60 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a64 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a68 [load]
(EE pc:0017AB18) TLB Miss, addr=0x60532a6c [load]
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.

So, as I'd normally would have liked to have this figured out myself and within ten minutes, that is not the case!

My PC's specs are:

MS Windows XP Professional SP3
AMD Athlon 64 X2 Dual Core Processor 6000+
3.5 Gigabytes of RAM
NVIDIA GeForce 8800 GTS

PCSX2 Specs are as follows:

Version 09.8

Emotion Engine: Recompiler
IOP: Recompiler
EE/FPU Advanced Recompiler Options: Chop / Zero
Clamping Mode: Extra + Preserve Sign

VU0: microVU Recompiler
VU1: microVU Recompiler

VU0 / VU1 Advanced Recompiler Options -
Round Mode: Chop / Zero
Clamping Mode: Normal

EE Cyclerate: 2
VU Cycle Stealing: 0
Enable INTC Spin Detection
Enable Wait Loop Detection
mVU Flag Hack
mVu Block Hack

And under game fixes, just the FFX Videos Fix.

Im going to thank you right now if you've even finished reading this.


Sponsored links

Sounds like you have a bad dvd / image, usually tlb miss means it can't read the sector. (like a scratch or fingerprint)
Anyone have a fairly generic save state in the Al Behd Home?
Or anywhere near there. Im not picky as to what the character stats are like atm, I'll just use an editor to fix that up.
If you have a memcard save close to there, load that instead of your state to see if it works. You should also try disabling all speed hacks and setting both EE and VU clamping to full and extra
[Image: newsig.jpg]
^ Agreed.

I think it is a savestate issue.
That is not too uncommon, so be careful when using savestates!
No luck, same effect. I tried the settings you gave me, as well as loading from the memcard instead of a save state. The same slew of messages came up in the debug.
Next suggestion is what hyakki told you, remake the ISO image from your disc in case it is damaged, I suggest using imgburn which is free and accurate.
[Image: newsig.jpg]
I'll let you know whenever my mate returns my original copy. He picked up a PS2 at the pawn shop and, next thing you know he has half my games!
well after sin destroys (i thinks its kilika) before the first sending i usually just set VU to Extra+Preserve and EE to Extra.
Thats The only part where you need it I beleive. Its the same for FFX-2, right at the beginning Cut Scene, where Rikku knocks a guy out, it freezes. But if only doing this doesnt help, then I guess it really could be a bad image.. when you get ur original copy and you make an ISO, Hopefully it will be better.
(OS:Win7_64bit ULTIMATE) (M4a88TD-M asus mobo)
[Processor:AMD AthlonII x4 645 3.720ghz(OC)Quadcore]
VideoCard-[ATIradeon5750(OC) 850mhz 2GB
RAM-[DDR3-4GB Matched RAM w/ Heat Spreaders]HYperX BLU
cpu-cooler- H60 closed loop water cooling.

Users browsing this thread: 1 Guest(s)