Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Jackie Chan's Adventures visual bugs
#1
So, recently, I was playing Jackie Chan's Adventures. And I tried all I could to fix issues including lightning problems for days and I couldn't. One of the bugs was how water would be shown on the right part of the screen (in a certain level) even tho there's no water where I'm walking. As you'd assume, such problems make the game almost unplayable. You can see the attached files yourselves. Every setting I did, brought no solution. The best result was when I turned skipdraw to "2". But that only brought another problem which was that half the screen was perfect while the other one wasn't showing some effects properly. I tried looking for an answer to the issue but found nothing online. To make matters worse, the game is not even listed on the website on the compatibility list which is kinda odd. And so I believe if there's one game that needs to be fixed for emulation it's gotta be this one.
EDIT: You can watch a PS2 walkthrough on YT of the first level and compare it to the screenshots. You will notice that the weird lines aren't shown.


Attached Files Thumbnail(s)
                                   
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(11-28-2020, 09:03 PM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]

Hello. Sorry for taking too long to respond as I got busy the past few days. And thank you so much for responding. Here's the contents of the emulog.txt file(I didn't "enclose" them as I don't understand exactly how and what do you mean):

PCSX2 1.6.0-20200506140834- compiled on May  6 2020
Savestate version: 0x9a0e0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 19041), 64-bit
Physical RAM    =  16301 MB
CPU name        =  Intel® Core™ i7-9700F CPU @ 3.00GHz
Vendor/Model    =  GenuineIntel (stepping 0D)
CPU speed        =  2.999 ghz (8 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins from C:\Program Files (x86)\PCSX2\plugins...
Bound  GS: GSdx32-AVX2.dll [GSdx 20200506140834 (MSVC 19.25 AVX2/AVX2) 1.2.0]
Bound  PAD: LilyPad.dll [LilyPad (20200506140834) 0.12.1]
Bound SPU2: Spu2-X.dll [SPU2-X 20200506140834 2.0.0]
Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200506140834 0.11.0]
(GameDB) 9858 games on record (loaded in 93ms)
Bound  USB: USBnull.dll [USBnull Driver 20200506140834 0.7.0]
Bound  FW: FWnull.dll [FWnull Driver 20200506140834 0.7.0]
Bound DEV9: DEV9null.dll [DEV9null Driver 20200506140834 0.5.0]
Plugins loaded successfully.

HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Current Renderer: Direct3D 11 (Hardware renderer)
Opening CDVD
isoFile open ok: C:\Users\dbzha\Desktop\Emulation\PS2 Games\Jackie Chan Adventures (Europe) (En,Fr,De,Es,It,Nl,Pt).iso
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (722096 sectors)
Opening USB
Opening FW
Opening DEV9
GSdx Lookup CRC:0
McdSlot 0 [File]: C:\Users\dbzha\Documents\PCSX2\memcards\Mcd001.ps2
GSdx Lookup CRC:0
McdSlot 1 [File]: C:\Users\dbzha\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA    v02.30(20/02/2008)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
# Initialize memory (rev:4.00, ctm:196Mhz, cpuclk:147Mhz detected)
Frame buffer size set to  512x512 (2560x2560)

PlayStation 2 ======== Hard reset boot
ROMGEN=2008-0220, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
<20080220-175343,ROMconf,PS20230WC20080220.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (400:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Sep  5 2006 12:57:08
  CPUID=2e20, BoardID=0, ROMGEN=2008-0220, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_524.12;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SCES_524.12;1) Game CRC = 0xAC4DFD5A, EntryPoint = 0x00110008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_524.12;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SCES_524.12;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SCES_524.12;1
0 00110000 0021e098 ..................................
Loaded, cdrom0:¥SCES_524.12;1
start address 0x110008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00110008 about to get recompiled. Load patches first.
SYSTEM: IOP Reboot Begin
SYSTEM: Initialising RPC
SYSTEM: Initialising DVD
SYSTEM: Rebooting IOP With cdrom0:¥IOPRP.IMG;1
SYSTEM: Syncing with IOP
Get Reboot Request From EE
GSdx Lookup CRC:AC4DFD5A
GSdx Lookup CRC:AC4DFD5A
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
cdvd driver module version 0.1.1 ©SCEI
Frame buffer size set to  640x512 (3200x2560)
loadmodule: fname cdrom0:¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥MCMAN.IRX;1 args 0 arg
loadmodule: id 26, ret 2
loadmodule: fname cdrom0:¥MCSERV.IRX;1 args 0 arg
loadmodule: id 27, ret 2
loadmodule: fname cdrom0:¥PADMAN.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥LIBSD.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥SDRDRV.IRX;1 args 0 arg
SDR driver version 4.0.1 © SCEI
Exit rsd_main
loadmodule: id 30, ret 2
loadmodule: fname cdrom0:¥USBD.IRX;1 args 0 arg
USB Driver (Version 1.1.0)
loadmodule: id 31, ret 2
loadmodule: fname cdrom0:¥APEMOD.IRX;1 args 0 arg
APETEC IOP Driver Version 4.320.01 (16/07/04)
Sony Libs Version 2.8.0
IOP_InitInterface: Done
USBKeyboard: Init Ok
USBMouse: Init Ok
SAFEMALLOC: 000b1b00 -> 000b5b00 (16K)
SAFEMALLOC: 000b5b00 -> 000b9b00 (16K)
STREAMING AND AUDIO SYSTEM INTIALISED (COLD)
SAFEMALLOC: 000b9b00 -> 000ba300 (2K)
Threads Init OK (011d0a29,011cf52b)
loadmodule: id 32, ret 0
SRC_RESET: FSystem==00000009, GTData0 = 003378c0, GTData1 = 003378e0, IOP_STATUS=004011c0, DVD9 Layer 1 Sector Start = 00000000
SAFEMALLOC: 000ba300 -> 000ba51c (0K)
SAFEMALLOC: 000ba600 -> 000ba828 (0K)
SAFEMALLOC: 000ba900 -> 000fa900 (256K)
SAFEMALLOC: 000fa900 -> 0013a900 (256K)
SAFEMALLOC: 0013a900 -> 0017a900 (256K)
STREAMING AND AUDIO SYSTEM INTIALISED (WARM)
SampleBaseAddress: 1f100, Free: 1923K
nStreams=3, RingBufferSize = 256k (768k), RingBufferSectorReadCount = 32
SFX_INIT_SYSTEM (Base Channel: 8, Channels Available: 40
SPU_SampleMemoryTop: 001FFFFF
SAFEMALLOC: 0017a900 -> 0017e900 (16K)
SAFEMALLOC: 0017e900 -> 00182900 (16K)
SAFEMALLOC: 00182900 -> 00184900 (8K)
SAFEMALLOC: 00184900 -> 00186900 (8K)
loadmodule: fname cdrom0:¥EYETOY.IRX;1 args 69 arg isoc=8
usbcam: max usbcams = 1, pack = 1, multi isoc = 8
usbcam: mic sample = 0, mic size = 0, frame size = 20480
usbcam: DMA thpri = 49, SIFRPC thpri = 50
loadmodule: id 33, ret 2
padman: *** VBLANK OVERLAP ***
padman: *** VBLANK OVERLAP ***
padman: *** VBLANK OVERLAP ***
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.93 fps
Frame buffer size set to  1280x1024 (6400x5120)
padman: *** VBLANK OVERLAP ***
Reply
#4
Try software mode, then give latest Dev build a try
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(12-05-2020, 12:01 PM)jesalvein Wrote: Try software mode, then give latest Dev build a try

I just tried the new build. Doesn't fix the issue either. Tried software mode and it fixed the problem but not exactly. It made the screen look slightly pixelated and lowered the quality greatly(which is to be expected from software mode).
Reply




Users browsing this thread: 2 Guest(s)