Jak and Daxter Games eye Issue.

GPU: RTX 2080 8gb
CPU: i7-9700K
RAM: 16gb DDR4
OS: Win 10

PCSX2 Build: Latest Nightly AVX2

All drivers are upgraded

Problem: im not sure if this is a regression, but in Jak and Daxter and Jak II the characters eyes are not showing up (Black voids instead)

on the wiki it says the issue is resolved, and ive seen footage of said fixes, however no matter what settings i use it the eyes are gone (software mode is fine however)

Sponsored links

Don't know what's going on. I just tested both games on the latest nightly build and they both looked fine. There eyes looked completely normal
Windows 11 64 bit OS
Intel Core i7-10700
Geforce RTX 2060 6GB
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
Pasted emulog goes here
[ /code]
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
(04-28-2022, 06:42 AM)envisaged0ne Wrote: Don't know what's going on.  I just tested both games on the latest nightly build and they both looked fine.  There eyes looked completely normal

That's odd, then its an issue on my part. i really don't see what I'm doing wrong...

Edit: it seems i found the issue, whenever i activate HW Hacks (to enable the fixes needed for the game) it causes the eye issue. even when i have everything on default. as long as Manual HW Hacks is checked, then the eyes are messed up.
You shouldn't need to manually enable any fixes anymore as it's automatic (that's why enabling manual hacks breaks it again). if you do we need to know about it so it can be added to the gamedb
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
As of 1.7.2915, Jak 1 is very blurry if everything is left on Automatic BUT you are using resolution scaling. I'm personally using 8X scale (2880p).

On Windows, in the new QT6 builds, you can currently set Offsets only globally, not per game. Using Offset Y: 300 globally in order to reduce the blurring in Jak 1 introduces the issue with the buggy eyes. What seems to fix it for me is enabling "Texture inside RT" under Hardware Fixes. Blending under DirectX/OpenGL/Vulkan has no impact on it.

Current setup: 5700 XT, driver 22.5.2, Windows 11 21H2. Happens on DX11/12/OpenGL/Vulkan.
I highly recommend using the no interlaced patch as well to reduce blurriness further if you're not already. Or turning on the disable Interlace Offset option as it seems to reduce blurriness also(not sure if it has any additional benefit if you're already using a no interlaced patch???)
I was under the impression latest Windows PCSX2 has fixes and patches in a database already preloaded?

Nontheless, I haven't yet tried adding a no-interlace patch. I'm just using the "No Interlace" option built-in PCSX2. The Interlace Offset Option doesn't make a difference.

I'm also curious in finding a proper Widescreen patch for Jak 1 given the original game just crops its 4:3 image for widescreen, ugh. And this I can't seem to find just yet. Not sure what behavior later Jaks have either.
Yes, Newer versions of PCSX2 come with both no interlace and widescreen patches for most games. You have enable them, as it seems you're already doing.

I don't think you will notice a difference using the Disable Offset Option if you're already using a no interlace patch.(i.e., have checked Enable No-Interlacing Patches option in Settings-->Emulation in qt builds)Edit: This is my experience using it with Jak/Sly 2 anyway. It doesn't seem to affect some games at all.

You have to actually change the screen ratio to 16:9 for widescreen patches to not crop the screen. Also, when you use a no interlace patch, you have to turn Deinterlacing off in the Graphics menu for it to have any effect.
I went and manually added both a widescreen and no interlace patch. I think I'm seeing more of the image now. The image is still very clean. Using "Deinterlace Off" and have "Use Patches" off all kinds enabled in PCSX2's settings.

Game now looks and runs fine.

Users browsing this thread: 1 Guest(s)