Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Katamari Graphics Bugs
#1
I'm running on a 3.06 Core Duo, I think it's Penrynn, with 4GBs of DDR3 ram, and a ATI Radeon HD 4670, with 256mb.

First off, am I right in assuming that We Love Katamari is completely non working on Mac? My copy keeps dying as soon as the intro screen starts.

More importantly, I did get my copy of Katamari Damacy up and running, with only two bugs, one minor, one huge. Minor one, occasionally the ball will get a big clear ring inside it.
No big deal, the big one however, makes it unplayable, but it happens off and on. It also gets these crazy dots you can see if you look closely.

I'll include a couple pictures, but it looks like the interlacing is getting screwed up, maybe? It's like every vertical line got swapped with it's neighbor, so the screen get's this blurry look to it.

Here is a picture of the weirdness:
[Image: FBLTe.png]

I'm running a 2.0 Bios, patches and console on, blockdump off, and here are my options set ups.
Graphics Options:
[Image: eHOWX.png]
Advanced Options:
[Image: IhgfY.png]
CPU Config:
[Image: TLkp3.png]
Speed hacks:
[Image: pca9p.png]
Game Fixes:
[Image: IsKSw.png]



I'm also getting another goofy artifact. Whenever I enlarge the window, the letterboxed/black edges end up with this spazzing out disco look. They flash and change constantly:[Image: 717JD.jpg]

Any help would be much appreciated, thank you.
Reply

Sponsored links

#2
The last artifact is probably due to wide screen option. In general, katamari should work. Have you tried last version of zzogl?
Reply
#3
Try turning microVU0 off. At least that usually fixes the graphics issues with Katamari in older versions on windows.
Reply
#4
Ah, I thought I was on the current version.

Just upgraded to it. Almost working, still getting that goofy blurring you see in the first picture though, like 70% of the time.
Reply
#5
I'm seeing the same thing (Katamari Damacy is the only ROM I have):

Macbook Pro 13"
2.66Ghz Core 2 Duo
8 GB RAM
Mac OS X 10.6.7
PCSX2 v0.9.6, ZZ ogl v0.21.213
Logitech Dual Action gamepad

Same PCSX2 settings as tjfallon above, except I'm running non-widescreen at 1024x768.

Problem seems to correspond to increased in-game screen movement... When I'm sitting still and not rolling around much, the "effect" disappears. It's not present on menus or cut-scenes.
Reply
#6
Oddly enough, the level "Corona Borealis" (the crown level) doesn't have this effect at all!
Reply
#7
have you tried the ZZOgl-pg 0.1.0 graphics plugin instead of ZZ ogl v0.21.213. Its the latest graphics plugin for snow leopard and is available on the pcsx2 mac downloads page. There is also a youtube video on how to install it: http://www.youtube.com/watch?v=YZNE-izx5yU

After installing make sure "“No logariphmic Z”" is clicked
http://pcsx2mac.net/files/zzoglPGlogz.png

I have found the performance is way better and there are less artifacts.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#8
(05-02-2011, 04:07 AM)mubbsy Wrote: have you tried the ZZOgl-pg 0.1.0 graphics plugin instead of ZZ ogl v0.21.213. Its the latest graphics plugin for snow leopard and is available on the pcsx2 mac downloads page. There is also a youtube video on how to install it: http://www.youtube.com/watch?v=YZNE-izx5yU

After installing make sure "“No logariphmic Z”" is clicked
http://pcsx2mac.net/files/zzoglPGlogz.png

I have found the performance is way better and there are less artifacts.

Thanks for this, but I keep getting a blank black screen when using ZZOgl-pg 0.1.0. It's odd, because our system configurations are very very similar.

Reply




Users browsing this thread: 1 Guest(s)