Thread Rating:
  • 2 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Killzone audio out of sync
#1
Hi guys,

Recently felt like playing Killzone again, so figured I'd give pcsx2 a go!

I installed it, left everything at the default/recommended settings (other than switching to D3D11 and upping the res to 1980x1020). It looks fine, plays at 60fps, but the audio is out of sync/skipping in-game and during cut scenes. Quite new to this, so figured I'd ask for a bit of help here!

Specs in case they're required:

Intel® Core™ i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz
GTX 580 1.5GB
16GB DDR3

Any helps/tips would be greatly appreciated! Smile
Reply

Sponsored links

#2
Use the latest PCSX2 SVN.

keep it in XAudio2.

Enable TimeStrech in SPU2-X, and change the Interpolation to see if any difference.

Drackard Wrote:Intel® Core™ i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz
8 CPU's.......?? Its 4 CPU with 8 Threads Tongue2.
Reply
#3
No speedhacks enabled.

Just got the latest SVN and that seems to have solved the sync issues (so far anyway!), but now I'm getting some vertical yellow lines, but I read someone that setting the drawframes to 2 solves this?

Will keep messing about, unless someone knows how to get it running perfectly! Tongue

--

Yeah, I'm too lazy to type it myself! Just copy/pasted from a dxdiag text doc haha Tongue
Reply
#4
I guess it is SkipDraw. Tongue2

Add the line in your GSDX.ini (it can be in my documents/pcsx/inis or PCSX2/inis(where you have installed PCSX2))

GSDX.ini Wrote:allowhacks=1

Then while configuring your GSDX, set Skipdraw to 2. Smile
Reply
#5
(10-17-2011, 04:03 PM)recoder Wrote: I guess it is SkipDraw. Tongue2

Add the line in your GSDX.ini (it can be in my documents/pcsx/inis or PCSX2/inis(where you have installed PCSX2))


Then while configuring your GSDX, set Skipdraw to 2. Smile

Perfect! Thanks so much for your help so far! Now I've got the audio syncing correctly and the game looking fine!

One last thing (sorry for being a pain! Tongue), the game seems to slow down at a times, almost as if time itself is slowing down (so voices, sound effects etc, also sound slower). Any ideas?
Reply
#6
Drackard Wrote:pain!

Thats nothing. Smile

Ahh. Try the Interpolation of Cubic. and use Speedhacks(try them just).
Tried Frameskip of 1, 2 or 2, 2.

Reply
#7
(10-17-2011, 04:18 PM)Drackard Wrote: ...
One last thing (sorry for being a pain! Tongue), the game seems to slow down at a times
...

Emulation is hard for the CPU, do use some speed hacks. For simplicity, try Presets 3/4/5.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#8
Try the MTVU Hack too. Smile
Reply
#9
Awesome! Using the 3rd preset with MTVU enabled seems to do the trick! Everything is running brilliantly so far!

Can't thank you enough for your help guys! Smile
Reply
#10
No need for thanks it was our pleasure. Smile
Reply




Users browsing this thread: 1 Guest(s)