Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
King's Field IV graphics glitch
#1
I've been playing King's Field: The Ancient City (King's Field IV), and there's a very annoying graphics glitch when using anything higher than native resolution.

There are small lines in liquids such as water and lava, and there are also two very prominent lines that criss-cross the sky. There's also some minor flickering on some textures. I've tried both v1.4 and several recent dev builds with the same results. 

The glitch is there regardless of which graphics API is selected, and I've tried all the available hacks.

I've seen a few other threads on the net where it's been mentioned, but no one seems to have a solution. Can this be put forward as an official bug, or does that only apply to things that occur at the native resolution?
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using, such as speed hacks or presets.
  • Your GSdx graphics settings (a picture of the settings dialog is preferred)
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
care to share a screenshot too ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
Windows 10 64
i7 4790K
Geforce GTX 1080
16 GB RAM

PCSX2 v1.4.0,
v1.5.0-dev-3007
v1.5.0-dev-3010

There's no point in listing any graphics settings because, like I said, I've tried them all. The issue persist among all APIs regardless of settings. I also tried all versions of GSdx that were included.

I was originally playing from the ISO, but I also tried the DVD after seeing the question. There was no difference. Both are NTSC. Do you think I should try the PAL version to see if there's a difference?
Reply
#5
The PAL version might not make much of a difference. But, that does depends on what game you are talking about. If you do own a PAL version though, it won't be compatible your NTSC-U savedata. Of course, it won't hurt to try. But again, make sure you own a PAL version as this forum doesn't support pirates.
PC Specs:
PC: HP Omen 15 dc-0051nr laptop
CPU: Intel i7-8750H (2.2 GHz up to 4.1 GHz)
RAM: 16 GB
GPU: Nvidia GeForce GTX 1060 Notebook (6 GB)
OS: Windows 10 Pro (64 bit)/Windows 8.1 Pro (64 bit)
Storage: 256 SSD PCi NV M.2+1 TB HDD
Need the latest GIT/development build? Click here!
Reply
#6
Here are some screenshots.


Attached Files Thumbnail(s)
               
Reply
#7
Perhaps someone else here has the PAL version and could check to see if it has the same glitch? I assume it does though as I wouldn't expect there to be any difference in the way the graphics are rendered.
Reply
#8
Do you get the same issue when game isn't upscaled?
And in software mode?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
(03-21-2019, 07:12 AM)jesalvein Wrote: Do you get the same issue when game isn't upscaled?
And in software mode?

No. As I said, it appears when playing in anything higher than the native resolution.
Reply
#10
It happen in various games, half pixel offset to special texture or special texure agressive should do the trick.
Reply




Users browsing this thread: 1 Guest(s)