Kingdom Hearts 1 - Grey Screen
Hi there, I could do with a bit of help for Kingdom Hearts [Pal] and the latest beta r1888.

When starting the game a second or two after selecting the disc image and hitting "Open", the game starts but the whole screen goes grey and stays that way (Pic), whilst the rest of the game carries on as normal. The sound runs well in the background, and I can hear the controller moving up and down through the different menu options (once the game presumably has reached the menu, though I can't see it!). If you leave it idle for a bit the demo/intro runs as normal too.

But what is really bizarre is how I (well it) got it to work. If you open the image, hit esc, open the image again, hit esc and open it again, on the 3rd try without fail the game runs with picture! I decided to carry on like this and guess what, it works without the grey screen on every odd number of tries after 3, for example 3,5,7,9,11,13,15,17... and probably carries on like this! Laugh

Is there possibly any way to fix this with settings my end? I'm not too frustrated now the game actually runs but it would be nice not to have to open the image 3 times Smile

No hacks, save states or anything. When it runs, it runs perfectly so many thanks to the coders, I've been really impressed how all the games look better than on the real ps2.

2.4GHz Quad Q6600
nVidia 8800GTX 768mb
No matter what settings I change for graphics it makes no difference. This is with the SSSE3 graphics plugin:
Direct3D10 (Hardware)
D3D internal res: 1024x1024

Many Thanks

Sponsored links

That is by far the strangest sounding predicament I'e heard in a while.

Then again its predicaments like these that make me like computers all the more-finding all sorts of pattern where one would think there is none to be found.

Anyway, I hae no idea, sorry, but I think it'd be a waste to post without SOME type of adice....
Cure all: Update your graphics driver
What plugins are you using and settings? If you're running from an ISO file make sure it is not mounted or used by any other program. Then configure the Linuz ISO plugin to point to the image file and use File->Run CD/DVD
[Image: newsig.jpg]
OK I updated the graphics driver and tried what you said about choosing "Run CD/DVD" instead of manually selecting the iso. To what I can see there seems to be no difference between Open iso and this option.

The same grey screen problem is still there but now the pattern has sort of changed and its takes a longer (aaah!) amount of esc, run, esc run to get to the usable game. It goes straight into the menu if I make a save state there. It seems more random now, whether this is to do with the updated graphics driver or me updating the config for Cdvdrom, its a guess. It starts perhaps around 9 now but from what I've tried it could be anything as high as 19 and it still seems to like odd numbers!!! (even numbers if you count from 0 Smile) Sometimes it gets back into the rhythm of every odd number after say 11,13,15,17 but it keeps switching around now so who knows Laugh

GSDx 1873 (MSVC 15.00, SSSE3) 0.1.15 (Res: 1024x768 60Hz | Renderer: Direct3D10 (Hardware) | Interlacing: Blend tff (slight blue, 1/2 fps) | Aspect Ratio: 4:3 | D3D internal res: 1024x1024 | (Tick) Allow 8-bit textures | (Tick) Wait VSync)
LilyPad svn (r1852) 0.10.0 - working well with a 360 controller
SPU2-X 1.2.0 default settings
Cdvdrom Linuz Iso CDVD 0.9.0
Dev9, USB, Firewire null. (On that note is there a working usb plugin for storage i.e. memory sticks or a folder on my computer? (it should make transferring saves easier!) I googled it for ages but got nothing but people wanting singstar and usb controllers to work.)

Well this is getting annoying now it takes longer! Out of interest what sort of info gets remembered after hitting escape?

That's very strange. Do you have any speed hacks on? Enable console and check if there are any errors printed there
[Image: newsig.jpg]
Okay all the speed hacks are off, with default cycle rate. Now its not starting on odd attempts, its even and this time more than every other attempt worked okay! I guess it depends when pcsx2 is run.

There are no errors printed to the console. I've compared console output for the good and bad startups and there is a slight difference, although it doesn't look like a cause really:

The "good" startups are always consistent with the console output.
The "bad" startups give two different output about 50-50 but are consistent between these. Of these two different console outputs, one is EXACTLY the same as the "good". The other differs in this way:

"Framelimiter rate updated (UpdateVSyncRate): 59.94 fps" is shown immediately after the bios version is shown (and Bios Warning > rom2 not found) and "NTSC Display Mode Initialized." is not displayed at all in the console.

Whereas in the working console. Framelimiter rate is displayed straight after "NTSC Display Mode Initialized." and these are located a bit further down in the console, after LoadElfFile, after Recompiler reset and after "* PCSX2 *: ExecuteBios"

Pic: Good Bad (and half the time Bad is the same as Good)

Just thought I'd post this even though hope looks slim of sorting it Smile Any ideas?
OK first stop with the odd/even attempts, the game is supposed to work with the first attempt always Tongue
I haven't seen this issue before and Kingdom Hearts is one of the most stable working games. My guess is some timing problems very specific to the PAL version of the game.
1)Changing SPU2 plugin to ZeroSPU2 and Peops SPU2
2)Changing the EE cycle hack to x1.5 or x2
3)Use an older GSdx plugin like the 0.1.14 release

See if any of these 3 make any difference in the way the game behaves
[Image: newsig.jpg]
Lol sorry I know it was beginning to get stupid Tongue But hey it was weirdly amusing!

The sound plugin didn't affect anything but there was some success with the EE hack! 1.5x and 2x seem to be the same and it goes into the game fine pretty much every time now. (EDIT: I set it back and its working the same as with hacks, guess its just working ok atm) The grey screen still happens sometimes (perhaps 1/10) but at the moment it seems to be better. As you said there seemed to be noone else with this problem which is probably a good thing! perhaps when I run it tomorrow the situation will be different!! What's the deal with running the speed hacks all the time as most people say they use them. Kingdom Hearts 1 & 2 seem to work well so is there any point? A bit more fps?

On another note do you know any USB plugins that emulate usb disk storage within pcsx2?
EE cycle hacks usually lower compatibility but in your case it seems the game has some issues and hacks can fix those (in very rare situations). They basically increase speed and lower compatibility. The gray screen is 99% a GSdx bug so try my third suggestion and use an older GSdx like 0.1.14 (you can get it from here: ).
No there is no such plugin, but whenever your memcard gets full you can always make a copy of the mcd file to keep it and create a new blank one, so you have infinite memcards.
[Image: newsig.jpg]
Thanks, I'll give that a go!

Users browsing this thread: 1 Guest(s)