Kingdom Hearts - Problem with controls
This should be an easy fix. Basically, for anyone who's played this game, you know that the directional buttons are not only used to move, but also to cycle through the menu when near an item with an exclamation mark above your head, also to cycle between "attack", "magic" etc. For some reason I am only able to use the buttons for one of these 2 functions at any time, and to switch between moving the characters and moving through the menu, I have to go in and remap the controller a bunch of times until it finally switches over. Very, very annoying. Any idea what I need to do?

Attached Files Thumbnail(s)

Sponsored links

Map the D-pad buttons too. These are the ones used in the menu
[Image: newsig.jpg]
It worked. Thank you.

What was giving me problems is that trying to map the left analog stick, lilypad would for some reason map it to the d-pad. So now I have to use only the right analog stick to move--the left analog won't work. No biggie of course, but if anyone else is having the same problem, just know you have to use the right analog stick.
EDIT: Nvm. Making new thread.
you do realize this is a forum, right?

as for your issue, reconfigure your joypad in windows
Hi Saiki,
Can you explain what you mean when you say that? How do I do that?
control panel > gamepads

rightclick and select "configure"
Well I've tried calibrating it (under control panel > devices and printers > define USB-gamepads i.e. the closest thing i could find in regards to what you described) but windows only seems to ask about the y, x and z-axis buttons. Won't do anything about the analog sticks, which is the problem here. I'm using windows 7 if that makes a difference. Am I perhaps not in the right place? There is no straight forward control panel > gamepads on my computer.
open help and support and type in "configure gamepad" then X and Y ARE the analog stick, as are Z1 and Z2
I hate to frustrate you but this is still not working. I tried calibrating, maybe I'm doing something wrong? When calibrating it asks me to rotate the "x-axis", so I rotate the left analog stick. Attempting to rotate the right analog stick makes the calibration skip to the next step. Then it asks me to push the "z-axis" all the way up and then all the way back down, but I try to do that with the right analog stick and I'm not sure it works.

Screenshot is of my current mapped controls. Do I need to switch something with something else or does everything look okay? Like I said, clicking "up" under "left analog stick" and then moving the left analog stick up maps the control to "up" under d-pad.


Attached Files Thumbnail(s)

Users browsing this thread: 1 Guest(s)