Kingdom Hearts - Shared ability lost after applying pnach cheat
I created a cheat for Kingdom Hearts

gametitle=Kingdom Hearts SLUS_20370 (U) [0F6B6315]
//MAX Power Up
//MAX Defense Up
//Max AP Up
//MAX Lucid Shard
//MAX Lucid Gem
//MAX Lucid Crystal
//MAX Spirit Shard
//MAX Spirit Gem
//MAX Power Shard
//MAX Power Gem
//MAX Power Crystal
//MAX Blaze Shard
//MAX Blaze Gem
//MAX Frost Shard
//MAX Frost Gem
//MAX Thunder Shard
//MAX Thunder Gem
Shiny Crystal
//MAX Bright Shard
//MAX Bright Gem
//MAX Bright Crystal
//MAX Mystery Goo
//MAX Gale
//MAX Mythril Shard
//MAX Mythril
//MAX Orichalcum

but there is one nasty side effect of this. The all shared ability will be lost after applying this.

I currently have two save games, one is the cheated one resulting in the shared ability being lost, and the other one is without cheat and the characters still have the "High Jump" ability.

I was wondering if there is a tool where I can compare the save states between equiping the shared ability on and off. That way, I might trace where the address of the shared ability is located.

I have tried adding the shared ability in the personal ability list by adding the codes from and decrypting it but it doesn't work. I can actually have the ability displayed in the personal ability but the characters act like nothing has been equipped.

Anyway, is there a program or a method where I can search the hex address and check the value when the shared ability is equipped in one savestate and unequipped in another savestate?

I tried Phaste since I thought it scans for memory address stuff but I can seem to get it to work on my computer. The game is running but no data is being displayed in the Phaste window.

I really appreciate any feedback regarding my problem. Thank you in advance.

Sponsored links

The emulator has a built-in function to basically do what you want. Under the Patch menu, I believe it's called 'Patch Finder'. It gives you the ability to filter the game state with mathematical operations.

Start the search with the option in a known state, toggle it, filter the results accordingly. Repeat until you end up with few enough candidates that you can check each one by hand.
Beware, you're making the assumption that you can figure out how to enable/disable the option once you know what memory address controls it. This is not always the case, so don't beat yourself up if you can't figure it out.

I know this isn't exactly what you want, but it's (IMO) significantly easier than directly comparing the files and trying to work out what's what. Tools such as Hex Workshop (or pretty much any hex editor) let you compare two binary files and highlights the differences, but this is likely to be a significant number.
"This thread should be closed immediately, it causes parallel imagination and multiprocess hallucination" --ardhi
Thanks! I have finally isolated what was causing the problem in my cheat. It's this:

//MAX Mythril Shard
//MAX Mythril
//MAX Orichalcum

The cheat works but it seems that it over rights something and causing the shared abilities to be lost. Do you have any other ideas in what to do next? Is there a way I can check the value of the address 003F2226-003F2228 while the game is running? I'd like to check the value and compare it to the list of values of items/abilities in the CodeTwink website.

Quote:Start the search with the option in a known state, toggle it, filter the results accordingly.

I am new to hex editing but I know I can get myself familiarized. What do you mean in a known state? The two states where it's ok and the one where the abilities are lost?
Changed "word" to "byte". Solved the problem
Hi, so im a complete noob at this stuff, so bare with me please...

I have the same problem as the original poster of this thread, i tried changing "words" for "bytes" and it didnt work, i even disabled the cheats, and still nothing.

I also did the very stupid thing of saving everything in the same save file in-game, so now i cant "revert" the effect, im probably screwed but if there's a solution please let me know D:
(05-30-2009, 04:32 PM)blue_francis14 Wrote: Changed "word" to "byte". Solved the problem

See why "byte, short and word" should be avoided from now on?

Supposing the codes are in the original raw form you just need to change any these three tokens to "extended" and all is fine.

In that specific case is fine using byte (although you really should replace them for extended). Be used to put "extended" in all your pnach files and no change in the code will never be needed.

That advice was given in several other threads and for a reason, the old usage (byte, short and word) is confusing and prone to mistakes from the user, mostly due to him/her not understanding clearly the importance of that length and making all sort of mistakes; another reason being sometimes is needed to change the first digit at the address code, a common one is changing every first digit to 2 and relying in the explicit length... that works, when it is comprehended but often the pnach becomes a mess.

Resuming: Using "extended" you can use the raw codes as they come, needing never to change them and the chance of error is minimal.
Imagination is where we are truly real
hi , i try to cheat Kingdom Hearts but i doesn`t work.

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_509.69;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SCES_509.69;1) Game CRC = 0xAE3EAA05, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCES_509.69;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
Cheats found!
comment: comment
Cheats Loaded: 24

my pnach file is:

gametitle=Kingdom Hearts [SCES_509.69] (PAL)

//AP Up
//Max Munny
//Infinite MP

pcsx2 0.9.8 found the cheats but, they don`t work in the game. please help^^
(05-11-2013, 10:45 AM)fghjklöä25 Wrote: hi , i try to cheat Kingdom Hearts but i doesn`t work.

pcsx2 0.9.8 found the cheats but, they don`t work in the game. please help^^

1) You should update to the new PCSX2 since 0.9.8 is fairly outdated by now
2) Make sure the cheats you got are for the PAL version of the game and not NTSC
Also make your own thread instead of hijacking an old one Smile

Users browsing this thread: 1 Guest(s)