Kings Field IV The Ancient City
Those who've played know the black door issue...I've been able to get past the 1st one with the negative clamp/full fix, but the 2nd black door will not go away. It's in the room 1 past the flaming arrow faces with a widda right next to a door, the hallway just beyond. Other people have had the issue but changing the clamping was supposed to fix it.
For those that don't know, 2 areas of the game fail to load the next areas. The only indication is a black doorway where a door should be. Entering it causes death. (falling I'm assuming as you can't see anything). does not happen if in the ps2.
I'm using SVN 1.3.0 5889, no speedhacks, MTVU breaks the game anyway. I've tried all the clamping options for both EE and VU, savestates, normal loading, all the hardware hacks, software mode, native with nothing checked, disabled widescreen patches, cheats, enabled game fixes 1 at a time and used the preset slider bar for all 6 presets. Tried interpretor and superVU recompiler then did it all again on stable version 1.2.1. FYI, the game does not stop, it just doesn't load the area beyond the door.
Is all lost? I can't have tried it all since the status says playable all the way through, but I'm not sure what I missed. I could put it back in my PS2 but I love how good games look on the pcsx2.

Asus Z87 Expert mobo
I7 4770K proc.
Asus GeForce GTX670
16GB Patriot Viper

Sponsored links

What does the emulog show during the freezing part?
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti

I just played through this game on r5875 and encountered the black void bug a few times. In most cases changing the clamping temporarily as suggested elsewhere let me get through the door. One time it didn't work, but I walked far away and came back and it worked the second time. So make sure you're walking far enough away from the void before each try.

Incidentally, how does your music compare to the soundtrack found on youtube? To me the emulated music sounds faster.. not sure if that's a game vs OST thing or an emulation issue.
im having this problem too, two times so far and i haven't even reached the end of the game.

the first time was in that room where you speak to the knight who's standing on his own Lance, when i try to return from that room the black doors appear and im left with no other option than reloading an old save.

the second is also close to that Lance knight, but from the other side, the south side of the city, theres a room i cant access because it has a black door so i have no idea what im missing inside it, or if it leads anywhere.

something very similar happens in Eternal Ring, another FromSoftware game, except that instead of a room leading into pitch black death, theres a certain path that autokills you when you try to pass through it unless you turn the EE roundmode to NEAREST.

edit: taken from some guy in youtube, tested it myself in r5875
There is a fix for this in PCSX2. You must change the EE recompiler option to "Negative" instead of "Zero/Chop", and then load up your game, and the game will successfully load the missing areas. Once you get into the previously missing area, change the EE setting back to "Zero/Chop," as it causes many other glitches.

it worked, black bugs gone
Make your own thread
[Insert Witty Sig Here.]

Users browsing this thread: 1 Guest(s)