Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Klonoa 2 crashing at startup
#1
I recently compiled PCSX2 in order to try Klonoa 2. I know this game has always been problematic and unfortunately it crashes on my system before starting. I have attached the emuLog.txt but here is the last line of the log:
Code:
j8 greater than 0x7f!!
On an older version, this would crash with an ASSERTION error. Now I managed to get this error once. Every other time it just crashes without a message.

Disabling the automatic game fixes allows it to boot, but then I get misplaced objects and can't get far into the game. I have tried switching between hardware and software and still nothing

GSdx settings:
OpenGL (Software is the same error)
Interlacing: Automatic
Texture Filtering (PS2)
Enable User Hacks/8bit textures/Large framebuffer all unchecked
Internal Resolution: 3x
Anisotropic Filtering/mipmapping/dithering/crc hack/date/blending all default

My specs:
OS: Debian 10.6 (Buster)
CPU: AMD FX-8350
GPU: NVidia Geforce GTX 1050Ti
RAM: 8GB DDR3


Attached Files
.txt   emuLog.txt (Size: 19,38 KB / Downloads: 50)
Reply

Sponsored links

#2
I have contacted the devs about this exact issue, with this exact game: https://github.com/PCSX2/pcsx2/pull/3451...-701316681

I think it's exclusive to 64bit builds of pcsx2. Our conclusion in the above thread (though not super well grounded) was that it's probably an issue with which build options you specify to pcsx2 during the cmake configuration step. I haven't checked which config option is the offender though. If you like, you should post on that github issue 1. How, exactly, you obtained your build of pcsx2, 2. if it's indeed 64bit (otherwhise, don't bother) 3. and tell them that, like me, you had issues with klonoa.
Reply
#3
Hmm. Now I can't seem to build. The make output show:
Code:
[ 35%] Building CXX object plugins/GSdx/CMakeFiles/GSdx.dir/GSCodeBuffer.cpp.o
In file included from /usr/include/wx-3.0/wx/msgdlg.h:14,
                 from /home/sdebian/pcsx2/common/include/PS2Eext.h:36,
                 from /home/sdebian/pcsx2/plugins/dev9ghzdrk/Linux/../DEV9.h:29,
                 from /home/sdebian/pcsx2/plugins/dev9ghzdrk/Linux/Linux.cpp:26:
/usr/include/wx-3.0/wx/defs.h:3477:33: error: conflicting declaration ‘typedef struct _GdkDrawable GdkWindow’
     typedef struct _GdkDrawable GdkWindow;
                                 ^~~~~~~~~
In file included from /usr/include/gtk-3.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-3.0/gdk/gdk.h:32,
                 from /usr/include/gtk-3.0/gtk/gtk.h:30,
                 from /home/sdebian/pcsx2/plugins/dev9ghzdrk/Linux/Linux.cpp:18:
/usr/include/gtk-3.0/gdk/gdktypes.h:143:39: note: previous declaration as ‘typedef struct _GdkWindow GdkWindow’
typedef struct _GdkWindow             GdkWindow;
                                       ^~~~~~~~~
[ 35%] Building CXX object plugins/onepad_legacy/CMakeFiles/onepad-legacy.dir/wx_dialog/JoystickConfiguration.cpp.o
/home/sdebian/pcsx2/plugins/dev9ghzdrk/Linux/net.cpp: In function ‘void InitNet(NetAdapter*)’:
/home/sdebian/pcsx2/plugins/dev9ghzdrk/Linux/net.cpp:58:12: warning: unused variable ‘ret’ [-Wunused-variable]
        int ret = pthread_create(&rx_thread, NULL, NetRxThread, NULL);
            ^~~
[ 35%] Linking CXX shared module libonepad.so
[ 35%] Building CXX object common/src/Utilities/CMakeFiles/Utilities.dir/pxStaticText.cpp.o
[ 35%] Building C object plugins/dev9ghzdrk/CMakeFiles/dev9ghzdrk-0.4.dir/resources.c.o
cc1: warning: command line option ‘-Wno-overloaded-virtual’ is valid for C++/ObjC++ but not for C
make[2]: *** [plugins/dev9ghzdrk/CMakeFiles/dev9ghzdrk-0.4.dir/build.make:142: plugins/dev9ghzdrk/CMakeFiles/dev9ghzdrk-0.4.dir/Linux/Linux.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
[ 35%] Building CXX object common/src/Utilities/CMakeFiles/Utilities.dir/pxStreams.cpp.o
make[1]: *** [CMakeFiles/Makefile2:645: plugins/dev9ghzdrk/CMakeFiles/dev9ghzdrk-0.4.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
I can't remember which options I used last time. This time I used:
Code:
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="*PATHTOHOME*/usr" -DPACKAGE_MODE=True
Reply




Users browsing this thread: 1 Guest(s)