Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
L2 button does not register
#1
I recently got into pcsx2 and my emulator does not register the L2 button when I press it on my controller which I binded correctly. It seems the only way for the L2 button to register is if I press the L2 button and then go into my lilypad settings, after I exit the settings menu my game finally reacts to the L2 button but only once after I exited the lilypad menu and the button doesn't register again. I also checked the FAQ and the General Troubleshooting thread and it recommends that I try different input pad plugins, however I installed Pokopom, SSSPSX, and Xpad and they all did not work for me. I also know that my L2 button is working because I tested it in a gamepad tester. I even tried binding L2 to something on my keyboard and the game still reacted the same after pressing the newly binded key on the keyboard, it only works after exiting the lilypad settings. I am currently playing jak 2. I also have a feeling that my R2 does not register but I am not far enough into the game to test that out yet.

Here are my lilypad settings thanks for any help.


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
Is that happens only with L2 or with R2 too?
What happens if you set some other gamepad button to L2 or R2
When you double click on XInput0 from Device Diagnostics and press L2,does Lilypad detect it as a single press

Here Z Axis is at 0.500 when the button is not pressed and when I press it,it start showing digits going down to 0
When you select "Right Trigger" from the list in Pad1,is the sensitivity set to 1.0
Reply
#3
(12-22-2020, 05:19 PM)vsub Wrote: Is that happens only with L2 or with R2 too?
What happens if you set some other gamepad button to L2 or R2
When you double click on XInput0 from Device Diagnostics and press L2,does Lilypad detect it as a single press

Here Z Axis is at 0.500 when the button is not pressed and when I press it,it start showing digits going down to 0
When you select "Right Trigger" from the list in Pad1,is the sensitivity set to 1.0

Unfortunately I'm not far enough into the game to test the R2 button and I am unsure what game allows me to test out both the L2 and R2 buttons early into the game. When I set the Left D-Pad to L2 the game responded the same as stated in the OP. However I found out that just going into the Lilypad settings triggers the L2 button, I don't even have to press the L2 button beforehand at all like I thought which confuses me.

I noticed that there is XInput Pad 0 and XInput Pad 1 under my Pad 1 list I'm not sure if that has to do with my issue.

When I checked the device diagnostics for XInput Pad 0, pressing the L2 and R2 buttons does not change the values, it just continuously remains at .494 and .451, in fact none of the values change when I press a button, however for XInput Pad 1, pressing the L2 and R2 buttons do change the values to 1.000 aswell as all the other buttons. And my sensitivity for both L2 and R2 are set to 1.0 from the list in Pad1.

EDIT: After getting further in the game now I can confirm the R2 button does not work either and its like the same with the L2 button I have to go into the Lilypad settings menu and exit for my R2 to register and then I can repeatedly enter and exit the Lilypad settings without pressing R2 for it to function.

EDIT: I found out that I can use the L2 function when not in a vehicle but the R2 function still does not work

Here is a picture of XInput Pad 0 and XInput Pad 1 and my sensitivity for R2 thanks for your feedback I appreciate it!


Attached Files Thumbnail(s)
           
Reply
#4
What happens if you completely remove X input pad 1 buttons and manually select x input pad 0 buttons in lilypad settings?
Reply
#5
(12-23-2020, 06:55 PM)prafull Wrote: What happens if you completely remove X input pad 1 buttons and manually select x input pad 0 buttons in lilypad settings?

After removing all the XInput Pad 1 configurations, none of the buttons on the controller worked, so then I deleted the XInput pad 0 configurations and reconfigured my XInput Pad  1 settings.....FINALLY all my buttons work. Although now I don't have an XInput Pad 0 I hope this does not give me any issues in the future.

I appreciate the replies you guys were very helpful.
Reply
#6
LilyPad also has Restore defaults that does the same thing, and clicking on the middle where it lists the number of keybindings you can rightclick to switch them also.
Reply




Users browsing this thread: 1 Guest(s)