Launching game from Run ELF will cause crash after 20 - 40 minutes.
I just want to post this on Bug Report Section, but still not sure if this really bug / not. Launching game from Run ELF will cause crash after 20 - 40 minutes.

# PCSX2 version: r5330 (orphis build)
# CPU options: EE/IOP recompiler. MicroVU recompiler, Round Mode Chop/Zero, Clamp Mode Normal, Speedhack disabled, everything else default
# Plugins used: GSdx HW DX11 , SPU2-X, cdvdGigaherts
# Windows 7 x64 SP1 Pro, AMD Phenom II X4, ATI HD 5850, 4GB RAM

Already tested on 2 games : Persona 4 NTSC (SLUS 21782) and Haunting Ground PAL (SLES 52877).
Not have much time to test other game but i bet this affect all game & many older revision of pcsx2 that launch using run ELF...

To Reproduce this :
1. Load ISO either with plugin or ISO selector (doesn't matter).
2. Launching game from Run ELF... (with game default ELF file).
Ex : If I want to run Persona 4, I just browse Persona 4 ELF File (either from mounted ISO / external location), in this case SLUS_217.82, then hit it.
3. Game launch. Play the game / just wait (doesn't matter), after 20 - 40 minutes it will crash (fixed crash time).

No log console print before / after crash. just crash.
[Image: elf%2520crash.jpg]
Yes i know, why bother launching game from ELF, not from run cdvd (fast/full).

It is because recent widescreen method that needed to modify ELF file.
I can "workaround" this crash by building ISO using modified ELF file and run with cdvd normally. But it's not optimal solution. Just want to run it with Clean ISO + External modified ELF, less storage required.

HDD price still expensive Tongue2

Sponsored links

Did you consider the possibility that this change to the elf could've caused this.
Did you tried starting the elf that way but the original one,not the modified.

PS.By default most of the logging methods in the console are disabled,try enabling them all and see what the console say once pcsx2 crash
Yes, i have tried it both with original & Modified ELF File. Same result.

How to enable all log ?
Where's that option location ?
In the Console the Sources menu
Aghh, those option is "very well hidden"
After many years, just noticed it now Rolleyes

Attached Full enable Log (include developer & CDVD).
Nothing unusual, just cdvd read before / after crash.

Attached Files
.txt   emuLog.txt (Size: 112,28 KB / Downloads: 564)
Maybe try disabling the Host File System from the System Menu in pcsx2...other that than,I at least don't see anything useful in the log
It's already disabled (Unticked).

If you / anyone have free time, just test it with my reproduce method on any game.
oh btw, narrowed it down, crash always happen after ~20 minutes from ELF launch (at least no more than 30 minutes).
Do I have to play or just start a game and wait 20min?
what happens if you run the widescreen patch as a pnatch cheat file instead?
[Image: ref-sig-anim.gif]

cloud101090 I started a game just to run(without playing)25 minutes ago by using Run ELF(extracted the elf from the iso and run it)but there are still no signs of problems,pcsx2 works fine

Edit: 35 minutes and still nothing.

Users browsing this thread: 1 Guest(s)