Left Analog Stick Acting Weird
I've already posted this on Reddit 10 hours ago, but got not answers, so I'll try my luck here.

Some time ago I played Persona 4, and all of my joysticks were acting pretty strange - sometimes the left analog stick stopped working alltogether and sometimes my character was walking in the opposite direction or walking on his own with me not even touching the joystick.

I blamed it on the cheap 5 $ joysticks but this Christmas I got a 60 $ Steelseries Stratus XL, and when I tried playing Obscure it happened again. At first everything is normal, but after a few minutes the left stick gets unresponsive or the character starts to walk by himself. If I restart the emulator everything works fine for a bit, but then the controlls start acting weird again.

I decided to try Rise of the Tomb Raider and Spyro 2 on PS1 emulator binding movement buttons to left stick - played for 30 minutes and had no issues whatsoever so I'm pretty convinced that it's PCSX2 fault.

I use LilyPad 0.11.0 plugin.

Tried remaining two plugins:
SSSPSX PAD Pressure Mod 1.7.1 - with this one I don't see a way to bind analog sticks - only the directional buttons.
TwinPad 0.8.3 - When I click Plugin Settings nothing happens. When I try to launch game with it it says 'Can't open COMBs file'. Though it loads game if I load it from emulator's save file, however, joystick doesn't work since the keys are not bound.

Please help.

Some specs:
Windows 8.1 Pro, 64-bit
i3-4170 CPU 3.70 Ghz
RAM: 12 GB
NVIDIA Geforce GTX 1060 6GB
PSCX2 1.2.1.

TL;DR left stick either unresponsive or character moves on his own. PC and PS1 emulator games run without any issues.

Sponsored links


Some update - it's not just analogue stick, but all the keys. After playing for some 10-15 minutes keys either start pressing on their own or become unresponsive. I have to restart emulator (sometimes even several times) for controller to work normal, but after some time it repeats again.

I tried using Lilypad, Popkorn and even binding controller keys to keyboard via JoyToKey, but nothing helps.

Please help. It's driving me crazy, and because of this I can't play anything using controller.

Users browsing this thread: 1 Guest(s)