Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Left analog stick has no 'up'
#1
Running PCSX2 with 'Vilros Retro Gaming Playstation 2 (PS2) Style USB Gamepad', I've successfully configured the controllers (LilyPad 0.12.1), but the left analog stick does not recognise 'up' in-game. I'm pretty sure this isn't a hardware issue, as the configuration recognises the input with no problem. I've re-entered all the controller inputs just to be sure, but no change. I can usually troubleshoot this kind of stuff alone, but I'm at a loss here, and you guys seem really kind from what I've seen on the forum Smile
Reply

Sponsored links

#2
Where do you get this problem ?
Every game, or game specific ?

Same in the bios ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Ya definitely check other games if you have any that you own. Some games don't utilize analog sticks or dpads.

FWIW... Cheap USB gamepads aren't guaranteed to work ideally. Does the input work with steam? Is there analog vs digital toggle on the pad? Have you tried switching input APIs? Try playing around with LilyPad settings, enable logging, turn off DirectInput... etc.
Reply
#4
Thanks guys!

I fiddled with some of the settings suggested by Mr.Wizard, none of which solved the problem, but then after switching back to LilyPad and reentering the inputs, I noticed on the list in the left panel that sometimes entering an input for one direction on an analog stick (this happened with left and right) would overwrite the previous input entered.

So, for example, after clicking 'Left Analog Stick: Right' and moving the stick to the right, it would show up on the list as 'DX USB Joystick, X Axis +, L-Stick Right', then clicking on 'Left Analog Stick: Up' and moving it up, that list entry would be completely replaced with 'DX USB Joystick, Y Axis -, L-Stick Up'. Both correctly entered for what they were supposed to do, but one replaced the other :/

Anyway, problem solved after chasing directions around for a while (as they occasionally replaced each other) until they were all there, dunno if it's a bug with LilyPad or pcsx2 or some quirky fault in the controller, but at least it's fixed Smile

Apologies if my reply is overly wordy, I wanted to clearly spell out the problem and my workaround in case anyone else encounters similar and goes looking for solutions. Thanks again for the quick replies, guys, sorry it took me a while to respond.
Reply




Users browsing this thread: 1 Guest(s)