Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Legion The legend of Excalibur
So, I picked up this game at my local pawn shop recently..
A few years back there was a bug report/thread, asking if there was a fix for the ground textures disappearing,
Surprisingly, They are still missing to this day, They load in but as soon as your character is on them they disappear for good. And no combination of settings brings them back, I know the game is not really well known. Or liked. But it was a game from my childhood and I would love to play it in the higher resolution that you can get with pcsx2, But the missing ground kinda ruins the entire experience.
If someone could look into it I would be entirely grateful.. I know it's a low priority for the team. But it's worth a mention.
[Image: xckarn-5.png]

Sponsored links

Does anything bring them back like pressing F9 or messing with the Clamping/Rounding modes for the EE or VU, anything at all help?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Nothing, Just tried all the fixes as well and nothing, And I wouldn't even be able to guess at what could be happening, I'm going to open the console and see if i can get any TLB miss errors or something.

Edit: Just constant looped sound messages. But it worked for all of a minute with VU I bit hack. then disappeared again.
[Image: xckarn-5.png]
That might be a good idea Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Doing a last ditch effort, Trying with EE set to interpreter.

Having EE set to Interpreter, With EEcache did nothing, not even hinting at an issue.
Same without EEcache. But the camera in interpreter gets caught on something, maybe the texture's are incorrectly being mapped to somewhere that the camera is being caught on.
[Image: xckarn-5.png]
Wow that is desperate, I don't fancy your chances.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
It was worth a try to see if there could've been any hint to a fix. I would post the log from console but no idea how to do a spoiler tag.

It also seems like one of those games that rely on the disc reader speed to do things. (a.k.a games like summoner where if you loaded them off harddrive on a ps2 the textures would pop in randomly)
[Image: xckarn-5.png]
Got some good news. for some reason, This time turning on software mode after getting into the game allows the textures to stay on the ground,

Edit: What it feels like. And I could be completely wrong on this... That the textures are getting flushed from memory due to the way the game streams from the cd/dvd/iso at all times.
[Image: xckarn-5.png]
Couldn't tell you to be honest. Would be good if you could provide a GSDump of the game so the GSDX guys can see if it's a problem on that end. If you need instructions on how to do it, check out this thread
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Made a post to the GSDX thread, This thread can be closed now, And hopefully (fingers crossed) it can be fixed for a future revision.
[Image: xckarn-5.png]

Users browsing this thread: 1 Guest(s)