Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Legion: the legend of excalibur
#1
Hello, i was just curious if there is any setting changes to fix the ground in this game on hardware mode? The game runs fine on software mode of course, just curious if there's a way to fix it in hardware mode.
Systems specs are windows 10 pro 64 bit, 12gb of ram, cpu is an i7-3770 and gpu is Nvidia GeForce GTX 750 Ti

EDIT 1/30/2021
Just adding the info that i was using native resolution.
Reply

Sponsored links

#2
Okay managed to find the answer myself. I'm using openGL hardware mode, and enabling the HW hack "preload frame data" fixes the ground. Haven't played more than a few minutes with this HW hack enabled, but it seems to completely fix the issue.
EDIT
Okay found a little time, sat down and went through the first level. Worked perfectly in hardware mode with what i described above.
Reply
#3
Did you tweak anything else to get it working properly? Preload frame data ticked on doesn't seem to solve the ground problem on my end.

After some further testing, enabling preload frame data does seem to fix the ground textures for me on Hardware mode, but this only works with the Internal Resolution set to Native (PS2). When set to a higher resolution, it causes the ground textures to disappear/go black once again.
Reply
#4
Glad you got it working. Guess i forgot to mention in the original post that i was using native resolution. I'll edit it to add that info, for anyone who might see this topic in the future.
Reply
#5
https://github.com/PCSX2/pcsx2/issues/4031

I was baffled that worked but i've used upscaling so it makes sense i suppose.
Reply




Users browsing this thread: 1 Guest(s)