LilyPad 0.12.1 Left Analog Stick Problem
Hello, this is my first post here.
I looked through a lot of threads before this to see if I could find a solution, but couldn't find anything particularly helpful.

Some info:
Windows 10
PCSX2 1.6.0
LilyPad 0.12.1
Controller is a wired Xbox 360 controller.

My games keep thinking I am pressing down on the left analog stick. Characters walk toward the camera.
In Spiderman 2, if I run forward and stop he will proceed to run toward the camera. However, if I WALK forward and stop then he will walk toward the camera at the same speed.
In Baldur's Gate DA 2, my character simply walks toward the camera.

I should note:
The games themselves work perfectly. It is just a controller issue.
I use a lot of emulators, and this is the only one that has this problem. My controller works perfectly everywhere else (RetroArch, mGBA, Project 64, Fusion 364, snes9x, etc.)
And in case anyone has this idea, PS2 emulation does not work in RetroArch for me, so I have to use PCSX2. It just crashes RetroArch.
I have tried increasing the deadzone, but it has no effect.

Images of my LilyPad settings:
[Image: 8LmaMTL.jpg]
[Image: xfwlJt2.jpg]

I appreciate any help at all!!!

Sponsored links

Nevermind I found the problem. For some reason the left analog has two settings tab: DX Controller and XInput. I had to change the deadzone in the DX Controller tab. No clue why there are two tabs for one input, but that was the solution.

I have a suggestion to the developers to include a graphical display of the controller outputs, such as in Dolphin:

[Image: s1fkI3K.jpg]

This is extremely helpful for troubleshooting analog stick issues, since you can see exactly how the emulator is interpreting your inputs. It also highlights the buttons when you press them (A, X, Y, etc) which allows the user to completely verify their configuration.

Users browsing this thread: 3 Guest(s)