Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LilyPad problem with flight simulation games
#1
Hi guys,

Recently I tried the AeroDancing4 and EnergyAirForce on pcsx2.
Have to say the pcsx2 is working quite good on these simulation games.

The only problem I met, which is the only problem causing my to lost most of my planes on the ground rather then in the air, is that my 'Rudder' is always automatically turning right when I start on the runway.

In the games, I always set the 'L1' and 'R1' buttons to control the 'Rudder' of the plane.
And in LilyPad configuration, I usually bind the 'L1' and 'R1' to some of the normal keys on my keyboard, ie. the 'Q' and 'W' keys.

So the thing is like this, when the game starts, my plane is on runway and I don't press any key, my plane spins right without moving forward by any bit.
Then I press the throttle to let the plane move forward, and click the 'Left Rudder' button to get the plane back to the middle of the runway. This does work but after a few seconds as the plane accelerates, the nose turns right the again so that I have to press the 'Left Rudder' all the way until it takes off and gets into the air.
Fortunately the auto-turning-right issue doesn't happen when the plane is in the air.

I think this should be a obvious issue that someone must have noticed before, since this appears immediately as you try any of the fly simulation games on PCXS2 with LilyPad.
So, could anyone give a clue about what's the cause and if there's any solution?

If not, I guess, this needs to be listed as a known bug for at least the LilyPad, so they could fix.


Thanks


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Had to correct myself a bit, which is in the EnergyAirforce, the plane automatically spins to the right even after it takes off.
This makes it impossible to play the game although the other aspects, like the sound, graphic, are all well emulated.
Reply
#3
Try altering the deadzone/sensitivity? Although it shouldn't matter with keyboard bindings.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#4
What are your settings?

Also, it's nice to see someone who's into flight sims on here.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
(12-14-2014, 08:15 PM)Blyss Sarania Wrote: Try altering the deadzone/sensitivity? Although it shouldn't matter with keyboard bindings.

This is a good consideration.

Giving the fact I'm using keyboard as mentioned in my post, the deadzone configuration in LilyPad is in GREY so it's not configurable.
Maybe we need to fix some other places.
Reply
#6
(12-14-2014, 08:27 PM)Nobbs66 Wrote: What are your settings?

Also, it's nice to see someone who's into flight sims on here.

Yes and I'm surprised there's no one who's ever tested or played these two sims coming into this thread so far...
Since these two sims had ever been rated very high...

What's more, it makes me now think the problem is actually not related with the LilyPad or any controller plugin...
The reason is that when I dug further into the EnergyAirforce game, I found that no only my plane, but the AI wing men are were spinning like idiots at the starting point of the runway...
That is, the four of them, all of the wing men planes were like the spinning torjan dancing in front of me when I was about to join the take off formation on the run way... which looks like a nightmare that for which I think I was be too frightened to sleep...

Since the AI planes are also spinning, then I guess it's not to do with the controller but something in the simulator itself. However, of course I'm not sure of that either...
Something maybe related to physical collision detection, or object model?
I think this may be something not related to the flight sims only, so hope could get wider suggestions or feedback.
Reply
#7
That second report leads to think it's an emulation problem, more specifically with the clamping and rounding modes. You may want to try the more complex modes under the EE/IOP and VUs. You can reach these options from the Config -> Emulation Settings. Try one at a time and verify, that would help pinpoint the cause.

Sorry I don't have the games and can't test it myself.
Imagination is where we are truly real
Reply
#8
Yeah, try what nosisab said. It's a good suggestion.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)