Lilypad LMB & RMB not working
So today I'm setting up my controls for PCSX2, using Lilypad 0.9.11, and after binding the X and O to the left and right mouse buttons, respectively, I enter FFX2. I noticed that all my other controls work fine, including the side buttons on my mouse, but whenever I press the left/right mouse buttons, nothing happens. I cycled through all the mouse input modes, to no avail, and opened up some PC games to make sure it wan't the mouse. Other PS2 games were also tried, including Armored Core - Last Raven. In the end I switched to TwinPad, bound X to the LMB, and voila, it worked!

So now I'm wondering why my mouse buttons won't work under Lilypad. I experimented with the latest beta, which didn't help. I've searched the internet, without any success, and now ask the community for help. So... any suggestions?

Sponsored links

post screenshots of your lilypad config
CPU Core [email protected] | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
(08-27-2009, 12:24 PM)zero29 Wrote: post screenshots of your lilypad config

Here you go. I've tried messing with most of the options already, this is just what they are now.

Attached Files Thumbnail(s)
First I've heard of this problem. Mouse directions do work fine, right? And the "sensitivity" of the buttons when you click on their bindings isn't below 1? You're using the latest version of gsdx, right?
Gsdx 1650. According to Lilypad, pressing the mouse buttons yields a value of "1" for each respective button. I switched the mouse mapping from right stick to left, then d-pad, and found that it would not respond. The joystick, when configured for left stick, did respond. The only buttons on the mouse that work are mapped by the mouse software to keyboard commands. Saitek Cyborg with latest drivers and software.

So essentially, according to the "Test Device," all parts of the mouse should work fine. I also tested with another mouse w/ different drivers, and found the same result.
#6 don't have a key bound to toggle mouse focus, and you have start without mouse focus selected, so I never steal mouse input. Just change that option or bind a key to "mouse" and press it on start.
Okay, I switched off the Saitek software profile and ran Lilypad's test. It picked up two of the side buttons, each returning values of 1. I mapped these to the start and select, in addition to keyboard mappings, and found that they didn't respond.
So THAT's what that option is for! The mouse buttons work now, thank you very very much.

Users browsing this thread: 1 Guest(s)