Lilypad detecting something strange
Hello to you all, this is my first post here.

I came seeking help to this problem I came across while playing on PCXS2 with my PS2 controller. Whenever I press the "down" button or a few times I press the "square", it understands that the "triangle" button was also pressed Sad. That annoys me a lot while playing, because it's like I'm pressing "triangle" out of nowhere. The image attached to this post shows the test ran on Lilypad 0.10.0. It only happens with "down" and "square", every other button is working properly.

I bought this controller recently, and it's the second time I'm using it. The first one was for playing on Dolphin, and I hadn't noticed this problem, I'm not sure if it only started now.

Will I have to throw away my new controller? Or is it some plugin glitch? Unsure

Attached Files Thumbnail(s)

Sponsored links

Could you play the game until you notice the glitch, then copy paste the log after it happened? it might help narrow down whether it's an issue with the plugin+^_^+
Signature purposefully left blank.
Unsure Well, the glitch doesn't start after some time, it's already there. If I run PCSX2, go to Lilypad config and test the controller, it'll already be noticed. So the log until I notice the glitch through that test would be the starting one, which only reveals some information about my computer. If I'm supposed to post the one after I load the game, it only contains some information about the image and stuff.

Anyways, I attached the log after starting the game, I'm not sure how it'll help, but I hope it does.

Also, thanks for helping me.Cool

Attached Files
.txt   log.txt (Size: 3 KB / Downloads: 187)
YW, but i don't know as much about PCSX2 as i'd like, but every day is a learning experience+^_^+
anyway, don't through away your new controller yet, does this happen when you have controls mapped to the keyboard? have you tried using a different controller?
Signature purposefully left blank.
The glitch doesn't happen when using the keyboard. Also, I had the idea to test the controller on other emulators, like Dolphin and Visual Boy Advance, and the problem appears there too with that goddamned "button 0" (which is triangle). Sad And unfortunately this is my only controller, I don't have another one to try.

So it doesn't seem to be a problem with PCSX2 or the plugin, which means I'm screwed.Glare
then your controller is faulty.
Sounds to me like a bad controller, Have you tried the manufactures website to see if it needs some kind of support drivers?
if its a usb controller maybe try another usb port on the pc.
Alright, first I tried changing USB ports, but there was no difference. So I went to the manufacturer's website, there were some drivers available and I installed them, but the glitch still happens. Sad

So if the controller is the problem, I'll first try to contact the manufacturer and see if they'll offer repair, but I'll probably get nothing because it's here from Brazil, and here nothing works the way it should. So I'll just ask you this last bit of help: where on the Internet could I get some information on how to fix it myself?
I think you should just RMA it and get a new one as a replacement from where you bought it. Unless it's just an old controller that it's dying...

But you said it's a PS2 controller, so maybe the adapter it's at fault?
[Image: nbKSK.jpg]
Thank you, people, I managed to exchange the controller, and problem's solved. Smile

Users browsing this thread: 1 Guest(s)