Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Mint 17 64bit libegl1-mesa:i638 issue
#11
Yes it is the shame that multiarch support isn't better supported.
Reply

Sponsored links

#12
(03-31-2015, 07:02 PM)gregory Wrote: Yes it is the shame that multiarch support isn't better supported.
When I try t oinstall 'sudo apt-get install pcsx2:i368' I get:

The following packages have unmet dependencies:
 pcsx2:i386 : Depends: libegl1-mesa:i386 (>= 7.8.1) or
                       libegl1-x11:i386
E: Unable to correct problems, you have held broken packages.

I don't know is it save to install those, because I have read on Mint forum that libegl1 breaks Cinnamon after logout from DE.
Reply
#13
sudo apt-get build-dep pcsx2-unstable:i386

And use proprietary Nvidia driver if you have that gpu. If you use AMD, it's kind of a toss up between Catalyst and mesa.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#14
Yes please use the unstable version which will be soon enough a stable version Wink
Reply
#15
Hi hrvoojex and Jehuty,


I would suggest installing Mint 17.3 64-bit and use my UPDATED INSTALLATION INSTRUCTIONS for PCSX2 in my 12/24/15 post, in this topic in the Linux Mint Forums:
http://forums.linuxmint.com/viewtopic.ph...5&t=168297
Reply
#16
@Roblm
Thank you for your answer. In the meantime I installed Ubuntu and successfully installed pcsx2 with unstable 32-bit package. Here is the thread
http://forums.pcsx2.net/Thread-SOLVED-Gt...th-murrine

For Linux Mint 17.3 64-bit I also received this answer
http://unix.stackexchange.com/questions/...899#251899
However, I didn't try it because I don't have Mint installed any more. In live usb mode it didn't work.
Reply
#17
I tried on linux mint 17.3 kde 64b http://unix.stackexchange.com/questions/...899#251899
this dont work.

as it is said it's a problem with multi arch and weyland, this bug is reported on linux mint

https://bugs.launchpad.net/linuxmint/+bug/1532706

Hope this will be fixed soon.

anyway

pcsx2 is installed and work very well on linux mint 17.2 kde 64bit
Reply
#18
Hello,

Today i made a new install of Linux MInt 17.3 kde 64bit to try again to install pcsx2 and it's a success !!!! Biggrin 

Use simply the "Software Manager" and then schearch for libwayland-egl1-mesa

You will have something like that :

   

You need the two packages installed (normal 86 and i386(32) ): for exemple in this pic :

libwayland-egl1-mesa
libwayland-egl1-mesa:i386


If for exemple you have only:
libwayland-egl1-mesa-lts-vivid

Then

libwayland-egl1-mesa-lts-vivid:i386

MUST BE INSTALLED.  Excl

I did this and no problem to install pcsx2 after Laugh
Reply
#19
Maybe I need to add the depency to EGL (even if it is SDL2 that depends on it).
Reply
#20
Yes but it is still a linux mint bug.

For exemple, i saw this problem with cinamon, the update was bloqued because he had the official "ppa" for dolphin (need certainly graphic packages i386)

disable this ppa solved his problem but he did not try this tip, don't know if it solve for others else me.
Reply




Users browsing this thread: 1 Guest(s)