Linux, PAL and NTSC
Hello everyone, first post here!

I am using the latest beta of PCSX2 linux binary on my Ubuntu 10.04 system. Now, the problem i have is the following:

I have got myself 2 PS2's, one from a store around the corner here in Sweden (PAL), and one I have imported from the states (NTSC). I have successfully managed to extract the BIOS'es from both of the machines and PCSX2 is recognizing both of them.
When I start up one of my old-time games (Crash Bandicoot: Wrath of cortex (PAL)) it runs without errors using my PAL-BIOS, but when I try to run .hack//G.U, Vol.1//Rebirth (NTSC) with my NTSC-BIOS, all I can notice is the sound and the clicks from whenever I press a button (aka, there's no video) but whenever the background color turns white (in-game) it also turns white in the PCSX2-screen, but I can not seem to find a way to make anything else visable.

I am able to see and maneuver through the PS2 system (boot without disc) in both BIOS'es.

Any clues to this one? I'm sorry if my english is hard to understand.


EDIT: I saw somewhere that it is supposed to be a Linux-forum here somewhere, but i'm not able to find it. Sry about that.

Sponsored links

You dont need to use diffrent BIOS for each game. The only thing you might need to do is use the Boot CDVD(fast) if your game doesnt match the BIOS, you can just use one BIOS for simplicity.

Your problem is probably the result of your settings plugins. Post your settings/plugins/pcsx2 version.
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
PCSX2 version:
0.9.7.r0 (svn)

The plugins:

Binding GS : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding PAD : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding SPU2 : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding CDVD : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding USB : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding FW : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/
Binding DEV9 : /media/1TB/PS2/EMU/pcsx2-0.9.7-r3881/plugins/

The settings:
BIOS = USA v2.00

  • Logging checked
  • Billinear Filtering Off
  • Interlacing None
  • Anti-Aliasing 1X
  • Widescreen Checked

Pad: OnePAD 0.1.0 (ZeroPAD didn't worked before)

SPU2: ZeroSPU2 Playground-Dev 0.4.6
  • Time Scaling Checked
  • Enable logging Checked

CDVD: Linuz Iso CDVD 0.9.0

The rest are nulls.

Any help?

UPDATE: I have now tried 2 other NTSC-games, Champions of Norrath and .hack//G.U Vol.2//Reminisce, and have now stated that it is the .hack-series that won't show me any video (the CoN-game showed me video, but not any of the .hacks).
Now I'm getting even more confused about this...
...Anyone out there who has managed to get the .hack/G.U-series to work? or anyone who knows the problem of mine?

Sorry about double post, but 1½ month later seems like a dead topic
For the sound, the better is to use the spu2x plugin.

Try to recompile a newer version and try to play with zz advanced setting. Be aware that the linux graphical plugin (zzogl) have a smaller compatibility than gsdx. I'm not sure your games are supported.

Users browsing this thread: 1 Guest(s)