(Linux) PCSX2 crashes when booting ISO (OpenSUSE 42.2)
So my issue is virtually identical to the one albc was experiencing in OpenSUSE 11.2. First, I installed the program using the YAST install Module from the OpenSUSE website, I run the program, and as soon as I try and run any ISO or CD, it will show a black screen, then the whole program disappears. (It crashes.)

I have tried all three video plug-ins with no success. The Libzzogl-0.4.0.so plugin was the first thing I tried, which game me a black screen for a few seconds, then closes the whole program. If I try the Null plugin, I just get this error:

/home/abuild/rpmbuild/BUILD/pcsx2-master/common/src/Utilities/Linux/LnxHostSys.cpp(70) : assertion failed:
   Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
   Thread:    EE Core
   Condition: false
   Message:   Unhandled page fault @ 0x00000000

[00] SysPageFaultSignalFilter(int, siginfo_t*, void*)
[01] 0x0x7f55449c8b10                            
[02] 0x0x2e2a005                                
Sorry for sounding like a noob, but I have no idea what I'm looking at.
Also, here is the program log when I try to boot for the first time:

PCSX2 1.5.0-0 - compiled on Jan 12 2017
Savestate version: 0x9a0c0000

Host Machine Init:
    Operating System =  Linux 4.4.62-18.6-default x86_64
    Physical RAM     =  3855 MB
    CPU name         =  Intel(R) Pentium(R) CPU  N3710  @ 1.60GHz
    Vendor/Model     =  GenuineIntel (stepping 04)
    CPU speed        =  1.598 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 43d8e3bf
    x86EFlags        =  28100800

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...

(PCSX2:3843): Gtk-WARNING **: Theme directory base/ of theme oxygen has no size field

Loading plugins...
    Binding   GS: /usr/lib64/pcsx2/libzzogl-0.4.0.so
    Binding  PAD: /usr/lib64/pcsx2/libonepad-1.3.0.so
    Binding SPU2: /usr/lib64/pcsx2/libspu2x-2.0.0.so
    Binding CDVD: /usr/lib64/pcsx2/libCDVDnull.so
    Binding  USB: /usr/lib64/pcsx2/libUSBnull-0.7.0.so
    Binding   FW: /usr/lib64/pcsx2/libFWnull-0.7.0.so
    Binding DEV9: /usr/lib64/pcsx2/libdev9null-0.5.0.so
Plugins loaded successfully.

(GameDB) 9709 games on record (loaded in 347ms)

** (PCSX2:3843): WARNING **: Invalid borders specified for theme pixmap:
borders don't fit within the image

So right out of the gate, PCSX2 is complaining about the GTK theme I'm using, saying it has no size field and invalid borders or whatever. Is the GTK theme the problem? If not, what should I do to fix this?


Sponsored links

ZZogl hasn't been supported anymore since 3 years. Ditto for GSnull. Those plugins aren't built by default and actually mustn't be built. Could you ask them to remove the option "EXTRA_PLUGINS".

Then, 1.5 isn't a real PCSX2 version, it ought to be latest GIT. But onepad 1.3 doesn't exist anymore. It is 2.0 now. And by the way, is it normal that files are inside lib64 path. Only the 32 bits version of PCSX2 is supported.
Quote:PCSX2 1.5.0-0 - compiled on Jan 12 2017
Binding PAD: /usr/lib64/pcsx2/libonepad-1.3.0.so
Thanks so much for pointing this out. The version I was working with was listed on software.opensuse.org. I guess it was compiled with a lot of incorrect information. For example, it was listed as version 1.4.0 when it clearly wasn't, and didn't fetch a lot of the required libraries it needed to run in the first place.

I removed that version of PCSX2 and installed a 32bit version from the YaST2 via the packman repository. Both the 32 and 64bit versions are incorrectly listed as 1.4.0+git20170221.0955-1.22, when in fact they are both version 1.5, and clearly aren't official builds. Neither of them work.

I'm just going to compile the official build from scratch and let you all know how that goes. Thanks for your help.

Users browsing this thread: 1 Guest(s)