Linux Pad Plugins - Gentoo
Newbie here, just trying to get things set up, and I'm having issues getting the OnePad plugin to work with xboxdrv, and I can't find downloads for other pad plugins for linux.

I'm obviously missing something *very* basic here, but I can't seem to find any info to help.

What am I missing?

Sponsored links

Hello there.
There is currently no other plugins than OnePad. However, it's very strange that it does not work with xboxdrv, it's supposed to be working.
So maybe begin by telling me:
1) What exactly is the problem?
2) Did you compile yourself?
2)a) If yes what are your compile options? In particular, SDL version.
2)b) If no, do you know the package options or can you give me a link to the info?
I do guess there is something wrong with your setup, but I need more info before I can help you.
Steps I go through:

I turn on xboxdrv (Userspace, non-daemon mode, flags: --dpad-as-button --no-uinput (uinput just segfaults on startup))
I press some buttons, triggers etc... xboxdrv outputs some text saying that it knows that I'm pressing buttons, triggers, etc...
I turn on pcsx2.
I go into the controller config page for OnePad.
I select the dropdown at the top that says "Keyboard/Mouse Only" - it has no other options.
I try selecting a button to remap anyway, and it doesn't detect the pad presses.

Yes, I compiled myself, I run on Gentoo.

The compile options are whatever the ebuild for 1.3.1 uses by default (I'm not an expert at digging through them), my only installed SDL version is 1.2.15 (gentoo ebuild revision 8 if that matters)
Okay, is there anyway you could try to use git version of pcsx2 and try again? If it does not work, try to install sdl2. And then compile yourself with ./ --sdl2 the git version. That might just solve the problem. Hopefully, your wxwidget is not linked to sld 1.2 ...

PS: Before that, is there kernel space mode to xboxdrv? You may try to use it.
Note on latest git SDL2 is enabled by default. However if you want to come back to sdl1.2 you need to add --sdl12
Tried the latest version of pcsx2 with gentoo's ebuild (there's a version 9999 that pulls the source straight from git), didn't work.

Then I took a look for sdl2 use flags, to see if I could use it easily. No luck.

Then I went looking for the source download to build it manually. I could only find version 1.2.1 here:

Where do I go for the actual latest? (Gentoo is claiming that there's a version 1.3.1, but I guess that might be a typo)

This: claims to need VisualC++ to work, so I'm assuming that it's the windows build, not the Linux one.

Edit: xboxdrv is only a userspace driver. No kernel space mode.
Here is the git. You can clone it Wink
This source package is heavily outdated. There is indeed 1.3.1 as stable. It's not a typo.
1.3.1 is not a stable release is a tag that was added because I whined about it (well there was a real reason, although it was mainly whining). The current stable release would be 1.2.2 or 1.2.1 if you are in Windows.

Users browsing this thread: 1 Guest(s)