Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux problems with Katamari and gsdx-ogl
#1
I have had this problem for about a week, and tried all morning today to find a solution to no avail, so I'm going to ask for help here as a last resort.

Hardware------
I have a pretty nice laptop. It came with Windows 8, and I've been able to use the Windows version of pcsx2 to play Kingdom Hearts and Okami, along with most non-emulated games, flawlessly. I've been on Linux for a few months due to some problems with Microsoft, but I have a dual boot just in case I need it. I am using Mint for my main OS.

The problem-------
I am playing Katamari Damacy on the Linux version of Pcsx2. The title bar says PCSX2 1.1.0.0 (svn) Jul 26 2013. As far as I know, this was flagged as unstable, but I have tested this with a stable build to have the same result. As with most games, it plays almost perfectly (60fps). However, whenever I stick something to the ball, the graphics suddenly get blurry, as if it was underwater. There is also a faint grid of 1 or 2 pixel width dots spaced far across the screen. The game lags a little during this time, but just a few seconds later, it goes back to normal. I can roll around and such, but once I pick something else up, the same thing happens.

I tried adjusting all the setting I could fine, including the advanced game fixes (which in some occassions broke the game)

I finally found that there was another option for a graphics plugin called "GSdx (GCC 4.7.3, SSE2) 0.1.16 [libGSdx-0.1.16]" as opposed to the ZZ Ogl plugin that I was adjusting settings for. So I loaded this plugin and went to test the game yet again. However, the game does not start and the program displays the error "GS plugin failed to open. Your computer may have insufficient resources, or incompatible hardware/drivers. Press OK to go the the Plugin Configuration Panel." After this, it opens the plugin panel, but whatever I do (even nothing), once I close the window it says "Warning! System plugins have not been loaded. PCSX2 may be inoperable." So just to test, I try running the game and the whole program crashes. If I return to the ZZ Ogl plugin, it runs as it did before without any issues other than the incredible blurriness when I grab items with the ball.

Reasons why I do not want to emulate on windows-------
Linux is better.
My best controller works on Linux only.
I can see it is almost possible, so why not bother getting it to work on Linux if I can.

What I understand-------
The plugin should work, since is it runs with OpenGL instead of directX
Only one person has had my exact problem.
Most people have no problems with software rendering in GSdx, but graphics glitches with hardware rendering.

What I haven't tried------
Other games
Emulating this game on windows

Sorry for this novel of a post, but I want you to ask as few questions as possible Laugh
Reply

Sponsored links

#2
To help, first start with the basics. CPU? Gpu? Open source or proprietary driver? Distro? 32 or 64 bit? How did you install pcsx2? Terminal output while attempting to run pcsx2 with GSdx plugin?
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
CPU = Intel Core i7-3632QM 2.2GHz

GPU = I have 2 (if I'm reading this correctly) Intel Corporation 3rd Gen Core processor Graphic Controler & NVIDIA Corporation GK107M [GeForce GT 640M]

Distro = Mint 15 Olivia x64

I installed it through the a link I found to Gregory's PPA, then installed via Synaptic

Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't
libEGL warning: failed to create a pipe screen for i965
EGL: Failed to create the context
EGL STATUS: 3009

EDIT: Not sure how to check if drivers are proprietary or not... :/
Reply
#4
sudo apt-get install mesa-utils

That will install program to run the next command...

glxinfo | grep -i opengl

AND

lspci | grep -i vga

What do those outputs say in the terminal?
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#5
[email protected] ~ $ glxinfo | grep -i opengl
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® Ivybridge Mobile
OpenGL version string: 3.0 Mesa 9.1.3
OpenGL shading language version string: 1.30
OpenGL extensions:

[email protected] ~ $ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)
Reply
#6
OK that's your problem why GSdx isn't working. Intel gpu + GSdx not yet supported. You need to get Nvidia card (not Intel) to be the main gpu being used. Use the proprietary Nvidia drivers.

sudo apt-get install nvidia-current

I'm not sure what else to do for Linux version to "force" the laptop to use Nvidia and not Intel graphics.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#7
Thanks for your help so far, but I'm not sure how to switch to nvidia drivers either. Once I find out, I will return here to post the results. I'll also be checking in to see if anybody else can help
Reply
#8
I will update ppa in the coming days it might work better. I fix lots of bug since july
Reply
#9
So, after much headache I've gathered that my particular Nvidia graphics card can't load regular Linux Nvidia drivers because of something called Optimus or somewhat. I've tried to get a driver loader called Bumblebee to work, but it can't find where the installed drivers are (Nvidia drivers I installed from Synaptic, I can't run them but the program is supposed to).

So in the process I've updated my kernel and headers to Sep 2nd, ruined my video drivers by attempting to install a proprietary driver (and failing due to some compiler BS), fixing my video drivers from this mishap, and now I'm pretty much back where I started.

I'm just going to let this sit for awhile until I want to come back to it, but I'll still check here in case anyone still wants to help Smile

The error I'm getting now is I run "sudo bumblebeed" with nvidia selected in the .conf file, and the program won't start, giving an error of being unable to find the nvidia module. I have checked file paths, half a dozen other config files and logs, tried alternatives (such as nouveau driver, but that crashes whenever I test it e.g. primusrun/optirun glxspheres), browsed the web (including Bumblebee on Github) and I'm all but worn out. Thanks for your help, I'll return here as soon as I get it working
Reply
#10
I never knew that laptop + gpu drivers could be such a problem.

That's why I generally stick to the desktop.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)