Loading a save state crashes PCSX2
Hi everyone, I've been a long time lurker but this time I have made an account to seek help for this problem I've been facing for months now.

Whenever I load a savestate, PCSX2 crashes.
[Image: kcc8sz.png]

And here's my pc
[Image: 2m4f98z.png]

Things I have tried so far:
• Tried different versions (0.9.8, 1.4.0, 1.3.0)
• Completely uninstalling and reinstalling
• Formatted my computer (I got a new SSD and installed same OS, windows 7 x64)
• Installed on a different drive/folder
• Used different plug ins
• Tried different games
• Checked my disk for any Badsectors (There's none)

There's so much more things that I've tried but I already forgot them.
This issue occurred about couple of months ago but I stopped playing pcsx2 and I didn't try to fix it since I've finished all my games.
Has anyone ever experienced this?

Sponsored links

Remove the Endless406.dll SPU2(Audio) plugin, and use SPU2-X instead.
(12-06-2016, 07:23 PM)FlatOut Wrote: Remove the Endless406.dll SPU2(Audio) plugin, and use SPU2-X instead.

I can't thank you enough. I have used different plugins but the only thing I didn't bother with was the Audio plugin.
Also, could this plug in be responsible for getting my savestates corrupted? I've gotten few errors with corrupted savestates as well even though it was just saved minutes ago.

Okay, I spoke too soon. Upon changing the sound plugin to SPU2-X, it worked however it's not giving me any sound for the game.
I have tried saving the game to memory card together with the ZeroSPU2 r5822, exited pcsx2, run it again and loaded the game through my memory card then did a savestate on slot 0, shut my pc down and when I tried to load the savestate it just crashes again.
Is it really necessary for me to use SPU2-X? It's not getting me any sound at all.
Load the save state,then save using the game saving function(saving the normal way),restart the game and load your save game

Save states are saving everything and when loading a save state created while you used something else(pcsx2/plugins),there is a big chance that the save state will not load or load with problems.
If you still don't have any sound after vsub's suggestions, it's possible SPU2-X is using the portaudio output module which sometimes doesn't work on default settings. To fix that, click the "configure" button just under where it says portaudio and tick the "exclusive mode" box, that should then give you sound Smile
[Image: ref-sig-anim.gif]


Users browsing this thread: 1 Guest(s)