Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loadstate occasionally fails in 0.9.8
#1
Ok so I'm finally getting so tired of this issue that I've decided after several months to voice my problem here. Please read carefully, as I'll be as thorough as possible.

Let me preface my issue by saying that I've been using this emulator for a good long while now, and have never encountered this problem until the latest public release. I should also state that I'm using the default CPU options, as well as no speedhacks or game fixes.

Also, it has affected every single game I've tried (25+) thus I'm quite positive it's not an ISO problem. The issue is also independent of my plugins, as I've tried mixing and matching more than I care to remember :/

So here is my actual problem...

When loading a file from any given loadstate slot, my emulator will occasionally kick out this message:
[Image: uglyerror.jpg]

The error itself is very random; sometimes I can load a dozen times without issue, other times it happens after just a couple of loads. After I receive the above error, I am forced to completely restart the emulator before any of my loadstates will function again. I should also say that loading is always successful on my first attempt after the emulator has been started/restarted.

I've tried about everything I can think of to resolve the issue on my own, such as renaming/moving the emulator's directory, running the emulator as admin, and I've also tried turning numerous options on and off (e.g. 'backup before save') all without success.

Searches through this forum and Google both lead to dead ends.

Here's a capture of the console output after I started the emulator, loaded from a loadstate, saved to a loadstate, then tried to load one more time, at which time the error popped up.

Quote:PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 (build 7600), 64-bit
Physical RAM = 4095 MB
CPU name = Intel® Core™2 Duo CPU E8600 @ 3.33GHz
Vendor/Model = GenuineIntel (stepping 0A)
CPU speed = 3.332 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0c08e3fd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Reserving memory for recompilers...

Loading plugins...
Binding GS : X:\XXXX\Playstation 2\plugins\gsdx-sse4-r1873.dll
Binding PAD : X:\XXXX\Playstation 2\plugins\lilypad-r1853.dll
Binding SPU2 : X:\XXXX\Playstation 2\plugins\spu2-x-r1857.dll
Binding CDVD : X:\XXXX\Playstation 2\plugins\cdvdPeops.dll
Binding USB : X:\XXXX\Playstation 2\plugins\USBnull.dll
Binding FW : X:\XXXX\Playstation 2\plugins\FWnull.dll
Binding DEV9 : X:\XXXX\Playstation 2\plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 250ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7600
ATI Radeon HD 4800 Series (8.17.10.1077)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: X:\XXXX\XXXX.ISO
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (697568 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: X:\XXXX\Playstation 2\memcards\Mcd001.ps2
McdSlot 1: X:\XXXX\Playstation 2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Japan v01.00(17/01/2000) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\XXXX;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\XXXX;1) Game CRC = XXXX, EntryPoint = XXXX
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\XXXX;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
> Selected savestate slot 0
Loading savestate from slot 0...
filename: X:\XXXX\Playstation 2\sstates\XXXX.00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
> Selected savestate slot 1
Backing up existing state in slot 1.
Saving savestate to slot 1...
filename: X:\XXXX\Playstation 2\sstates\XXXX.01.p2s
Saving GS
Saving PAD
Saving SPU2
* SPU2 > FreezeSave > Saved 694 cache blocks.
> Selected savestate slot 0
Loading savestate from slot 0...
filename: X:\XXXX\Playstation 2\sstates\XXXX.00.p2s
(gzipThread) Data saved to disk without error.
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
> Selected savestate slot 1
Loading savestate from slot 1...
filename: X:\XXXX\Playstation 2\sstates\XXXX.01.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
Unexpected end of file or stream.
Path: X:\XXXXXXX\Playstation 2\sstates\XXXX.01.p2s
(pxActionEvent) (VM_UnzipFromDisk)

All significant PC specs should already be in the console output, but if I should elaborate more just let me know.

Of course, any help would be very appreciated. Savestates are about my most prized feature in emulators Smile So I'd really like to get this issue resolved. (I refuse to rollback to a previous pcsx2 version, I love this version's interface too much Laugh)

P.S. Note my near zero post count expresses the fact that this is the first time I've ever had an issue with the pcsx2 I couldn't resolve on my own Tongue
Reply

Sponsored links

#2
Known issue, no known solution other than waiting 'til it's fixed in the future or making more save states just to make sure.

This is a current bug report on this issues:
http://forums.pcsx2.net/Thread-Cant-load-up-my-sstates


When there's a backup available you have to load it from the main menu "System > Load State > backup" when you're running the game and on the slot that had the state.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Thanks for your prompt reply.

It's actually not necessary for me to make backups of the savestates, the files themselves aren't even corrupted. I simply restart the emulator and it reads the savestate correctly once again.

The emulator itself is randomly deciding to stop reading the filestream properly for whatever reason.
Reply
#4
Hmm... Squall-Le says the problem with save states is the file handlers and that could be more your problem then, would be a matter of waiting more between saves/loads and there would also be no other fix for now than to either wait until it's fixed or just closing/loading the emulator as you've been doing... or using the save states feature less ;p
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Thanks for your help Laugh If I get bored I'll try debugging it.

This same error message can be replicated by switching certain plugins before loading a savestate, but I assume that is by design.
Reply
#6
try a more recent build, avih changed how the backup file is made which might help... might not too.
Reply
#7
4600 is the most recent isn't it?
Reply
#8
That's the latest stable, you can try the latest SVN build:
http://forums.pcsx2.net/Thread-SVN-daily...-by-Orphis
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
Also do you have PCSX installed in Program Files?? If so try to install it into another directory, like My Documents or a selfcreated directory, could also be a permission problem, atleast that's the way How I see it (I can be wrong ofcourse) Smile
Reply
#10
Alright I'll test the SVN build out sometime this week and let you all know if I still encounter the issue.

As for the directory the pcsx binaries are in, as I stated in my original post I've tried both moving and renaming the base directory which had no effect.

I'll see if manipulating the permissions works, but I don't think that is the issue here. In my humble opinion, incorrect permissions would cause consistent errors, not something as random as this. But as I said I'll try changing them around to see if that has any effect.
Reply




Users browsing this thread: 1 Guest(s)