Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS and High GPU usage even on software mode with Nvidea card.
#1
High I am having trouble getting a FPS above 60 for Final Fantasy X using NVIDIA GeForce GTX 1050 Ti with Max-Q Design. 


I played around with the settings a lot (Software/Hardware mode OpenGL/Direct3D11, hacks etc) mode and it keeps maxing out on 60 FPS. (I am testing in turbo with a much higher limit or without any frame limit at all.)
If I look in the Task Manager find that indeed the GPU usage is 100%, even in software mode. Should it not use the GPU hardly at all in software mode?

Occasionally by changing some settings it goes to 30 FPS instead (again such a round limit is suspicious).

Just before asking for advice here I managed to solve the low FPS issue by using Software mode and switching to Intel UHD Graphics 630. Now everything works fine with 100FPS. So now I know the issue is definitely with the NVIDIA card. But this is still very strange because the NVIDIA card should be at least 4 times as powerful as the Intel UHD Graphics. Moreover, on Software mode it should hardly show use right? Am I configuring something wrong?

(Also I am sure it is PCSX2 using the 100%GPU and not something in the background.)


Apart from specs mentioned above: Windows 10, Intel Core I7-8750 2.2GHz.


(BTW first time poster, hope this is the right place to ask such a question, otherwise I am sorry.)
Reply

Sponsored links

#2
1 - tried enabling vsync ?
2 - it won't go higher than 60 fps unless you want to speedup the game. game speed is synced to fps.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
If you have nVidia Experience installed,there is an option for power saving that is reducing the fps
There is also another option that may limit pcsx2 to 40fps
If VSync is enabled and your screen refresh rate is 60 you will not get more that 60fps(I think this problem existed on some pcsx2 version but it's fine on the latest beta but the speed WILL be limited if vsync is enabled in the nvidia control panel)

Half speed(30fps)can happen if you press Shift+Tab
Reply
#4
(05-04-2019, 02:35 PM)vsub Wrote: If you have nVidia Experience installed,there is an option for power saving that is reducing the fps
There is also another option that may limit pcsx2 to 40fps
If VSync is enabled and your screen refresh rate is 60 you will not get more that 60fps(I think this problem existed on some pcsx2 version but it's fine on the latest beta but the speed WILL be limited if vsync is enabled in the nvidia control panel)

Half speed(30fps)can happen if you press Shift+Tab

Thanks! Wow that was so stupid of me. Fixed the issue simply by plugging in the power adapter. I should have thought of that but hadn't even noticed I was using my laptop on battery. I do not have nvidia experience installed but indeed it seems some power saving settings are switched on somewhere by default for the NVIDIA graphics card (when not charging).
Reply
#5
From the wiki page, I saw that Software mode gives better FMVs. However, Hardware mode combined with all of the fixes should give you a stable 60 fps when plugged in during the rest of the gameplay.
PC Specs:
PC: HP Omen 15 dc-0051nr laptop
CPU: Intel i7-8750H (2.2 GHz up to 4.1 GHz)
RAM: 16 GB
GPU: Nvidia GeForce GTX 1060 Notebook (6 GB)
OS: Windows 10 Pro (64 bit)/Windows 8.1 Pro (64 bit)
Storage: 256 SSD PCi NV M.2+1 TB HDD
Need the latest GIT/development build? Click here!
Reply
#6
Also F4 is the framelimiter.
Reply




Users browsing this thread: 1 Guest(s)