Hey guys,

It seems that I have a problem running FFXII on a playable fps (35-40++).

In the opening movie, it runs perfectly at 60 fps throughout, but during the first cut scene, fps can drop from 40+ to 20, and during the actual game play, fps is at 20-25 max. The thing is that my brother's computer has exactly the same specs as mine (except for the graphics card, mine is a Radeon HD4770, his is a GeForce 9600 GT), but he runs the game at 45++ fps whereas mine is only at 20-25 fps.

He uses the default plugins, with his gs set to native resolution and fullscreen. I tried it as well, but there was no improvement. In fact, I've tried all the speed hacks possible, but it doesn't work either. I've even done some frame skipping. The results were the same.

This is the spec of my com:

Processor: Intel® Core™2 Duo CPU E6550 @ 2.33GHz
Memory (RAM): 3.00 GB
Graphics: ATI Radeon HD 4770
Gaming graphics: 1790 MB Total available graphics memory
Windows Vista Service pack 2 32-bit OS

My PSX2 specs are the default given for the 0.9.7 version other than gs being set on native resolution.

Thanks for any help available, or any explanation as to why my bro's fps is faster than mine despite same specs (I don't think the difference in our graphics card is very significant...)

Sponsored links

It's a weak CPU for this game.
*SuperVU [Legacy]
*Set clamp mode to "None"

It's strange that native and speedhacks did nothing at all.
Thanks for the help. It's a weak CPU, but my bro's CPU which is the same as mine can handle it just fine, which is very weird.

I tried as you suggested- but no difference in fps.

Any other ideas?
Run the game in software mode and tell your brother to do the same, if the FPS are similar then it's the graphics card making the difference Smile
Say, is a E6600 @ 3,6Ghz also a weak cpu for this game? I get sometimes slowdown to 30fps, mostly it runs at 60fps. 30fps for example outdoors in Giza Plains. I get typically 92-100% EE, and GS around 22%.

I've tried speedhacks of the latest public version, and while it's helped some, not nearly enough.

I tried these:
*SuperVU [Legacy]
*Set clamp mode to "None"

And it raised the FPS to 38 in the same scene. Anything else I could try?
in my case SuperVU tends to hang the emu which i don't like a bit..
Kaerwek ur CPU is powerfull as it is compared to my laptop CPU..haha..
maybe some settings tweak and u'll be fine..
run with native resolution and use DX10 if u can..
[Image: 871087.png]

*Mio sees a ghost for the first time*
Mio: Aaaaaaah!! x_x
Seriously, the way she acts, you'd think she grew up with ghosts.
Right, tried with native res, DX10, and it doesn't really affect the EE percentage. FYI I've got an 8800GTX.
I think that you should be able to run it at 36+ FPS. Enable all speedhacks and put both cycle steal time to max. Can you take a screenshot,or tell us percentage of use EE tread and what about GS tread when FPS drops. Maybe you have malware on PC?
I don't think malware is affecting anything. Hardware monitor doesn't show that CPU nor memory is a bottleneck (Got 30% cpu time on idle while PCSX2 draws about 60-70% of the CPU time).

Righto, experimented some. I used to have in GS 1500x900 D3D resolution. Without speedhacks, it gave me in a landscape scene some 33fps.

With speedhacks enabled, it gave me 36fps.

When I turned 'Native Resolution' on, my fps jumped to 46fps with all speedhacks turned on. When I dropped the EE cyclerate from 3 to 2, it went down to 43fps. I guess I can be content with that. However 'Native Resolution' sure looks ugly. Tongue

Do you guys really play with Native resolution on?

1280x800 D3D internal res gave me a fps of 40, think I'll settle with that. It looks fairly good.

Users browsing this thread: 1 Guest(s)