Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS on parts of Kingdom Hearts 2.
#1
Hi, I'm new to this forum. I just wanted some help and searched every where and couldn't find the solution to my problem. I ran the first Kingdom Hearts nice and smooth without any FPS drops. Now that I started KH2 I noticed a lot of FPS drops around 30-40. I also have a really decent laptop.

Processor Intel® Core™ i7-3630QM CPU @ 2.40GHz, 2401 Mhz, 4 Core(s), 8 Logical Processor(s)
8gb RAM
Windows 8
Nvidia GT 650M 2gb

Can someone tell me optimal settings for my emulation? I would appreciate it.
Reply

Sponsored links

#2
KH2 is more demanding than KH1.
2.4 Ghz may not be enough for intensive scenes. you'll have to experiment a bit with speedhacks.

oh, and of course, set your power plan to high performance and disable intel speedstep if you have a good cooler.
Be aware running pcsx2 on a laptop isn't recommended since it's CPU intensive.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
It seems your PC Specs are up to snuff (Decent? That's insanely high end for a laptop), but perhaps try to lower the internal resolution, (this can be done in the Core GS settings); Enable MTVU; the mVU Flag Hack and enable INTC Spin Detection. Also what can help is setting your Cyclerate to 1 and your Cycle Stealing to 1. This should give you a large speedboost, unless of course you have them all already enabled, in which case, just lower the internal resolution, it may not look as good, but beggars can't be choosers.
i7 3770K @ 5.1GHz | Corsair Hydro H80
AMD Radeon XFX 7850 Black Edition @ 1.35GHz
8GB Crucial Ballistix 1866MHz RAM
MSI MPower Z77 ATX Motherboard
5TB Total Storage Space 2xHDD / 1xSSD
Corsair AX860i 860W Digital ATX Power Supply
Reply
#4
not really....he still needs to plugged-in the AC power and pcsx2 hates batteries.
if it's still slow he will welcome to try to use "constant skipping" (Emulation settings-->GS)
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
Alright I'm going to try what BoxPossum says and see if it ends up with any better results.
Reply




Users browsing this thread: 1 Guest(s)