Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS 2 unplayable
#1
Hi all,

I am new here, 
I am trying to emulate Metal Gear Solid 2 Substance (PAL) but after 1 min into the game, the framerate drops to 3-4 fps (and horrible sounds).

I have tried both 1.4.0 and 1.5.0 (of today) with GSdx AVX2 and both OpenGL and Direct3D11. Always the same result.

I have an i5-8400, and RTX 2070 Super, 16GB DDR4 and I am loading it from a ISO in an M2 SSD.

The first minute of the cutscene run at 60fps with 3x native resolution, then the drop. Even with 1x native resolution.

Is there something I am doing wrong here?

Thanks
Reply

Sponsored links

#2
That shouldn't happen, even on my old PC with an i5 3570k and a GTX 770 I was able to run the game at 3 or 4 times resolution without issue.

Which speedhacks did you enable? Go for all the recommended ones and activate MTVU.

At the moment I can easily run it at x4 resolution and at 1080p on my laptop.

Also your CPU's STP is very very slightly below mine so it shouldn't make a difference.

Let me know if you need help with the configuration.
-PC Specs-
AMD Ryzen 3600
16gb DDR4 Corsair 3200mhz
MSI Armor Radeon RX580 8gb 
Windows 10 Pro x64 
-Laptop Specs-
i7 6700HQ @ 2.9Ghz
8gb DDR3 
GTX 960m 4GB
Windows 10 Pro x64
Reply
#3
Thanks for the answer,

All hacks were on presets.
But tried again and it works fine now.

I don't know what could have been, very strange!
Reply
#4
Emulation is strange, sometimes stuff like this happens. Glad you got it sorted Smile
-PC Specs-
AMD Ryzen 3600
16gb DDR4 Corsair 3200mhz
MSI Armor Radeon RX580 8gb 
Windows 10 Pro x64 
-Laptop Specs-
i7 6700HQ @ 2.9Ghz
8gb DDR3 
GTX 960m 4GB
Windows 10 Pro x64
Reply




Users browsing this thread: 1 Guest(s)