Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS 3 Slow motion problem
#1
Hey guys !
I have started using this amazing software today for the first time
slowly getting the hang of it Laugh
My problem right now is that i get a very bad performance on Metal gear solid 3
when i play the game the fps show 40-50 but the game goes Slow mo Hard!
I have tried and played a different game using the pcsx2 Onimusha dawn of dreams and the game runs great 60fps + no slow mo problems at all
just the metal gear :L
My specs
AMD FX 8320 8core 3.5GHZ
16 GB DDR3 ram
Nvidia 760 GTX 4GB overclocked
Windows 7 64 bit

Is there a fix for the slow mo or is my computer too weak for the emulator ?
Reply

Sponsored links

#2
your cpu isn't too weak for the emu, it's just too weak for mgs3 cutscenes.
but you should get near playable speeds with some speedhacks when it comes ingame
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Your computer is decent for PCSX2, but MGS3 is one of the more demanding games(especially cutscenes). Things you can try:

Config->Emulation and go to speedhacks tab

Enable MTVU
Set the left slider(EE cycle rate hack) to 2.

Try that first. If it's still a bit slow, try putting the other slider to 1 or 2, but that might give you false FPS.

Your best shot would be overclocking your CPU to the 4Ghz range. I have an FX6300 @4.4Ghz and it runs almost all game at full speed. You don't really even need to go that far, as I had good results at 4.1Ghz as well. But watch the heat, the vishera chips make a lot of heat and if you are using the stock cooler you will most likely end up getting throttled if you go too high!
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#4
hhahaha WOW thanks so much for the fast response !
hmmm Its wierd though cause the cutscenes run smooth just the game
especially when ***** hits the fan gets hardcore slow mo
but yeah i will try the speed hack and report back in few minutes : )
Reply
#5
Hmmm there is a big improvement but can any of you explain why does the game so bad even though it says on top of the window that the game is running at 50 fps non stop ?
Reply
#6
(04-06-2014, 10:52 PM)Takedas Wrote: Hmmm there is a big improvement but can any of you explain why does the game so bad even though it says on top of the window that the game is running at 50 fps non stop ?

(04-06-2014, 10:45 PM)Blyss Sarania Wrote: If it's still a bit slow, try putting the other slider to 1 or 2, but that might give you false FPS.
Reply
#7
The speedhacks can cause fake fps. That is, it says full speed in the title bar, but it's not actually full speed.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
Awww its a shame i cant play this game properly
the slow mo is unbearable i guess i wont be able to play it Sad
Reply
#9
You can try to set Clamping mode to none. This is faster but reduces the compatibility. So maybe you will see a crash. Then you have to reload using a in-game save-function and set it back to the default value.

You can also play with the VU compiler and use SuperVU instead. It can be used as a speedhack but can also break everything.

Still you can think about overclocking if you have a non-boxed cooler...


Actually some guys now said setting the default fps from 50fps (pal) to 25fps and then using the turbo-mode (200%) you can get a speedboost. Always wanted to try that but didn't have time or just forgot it.
Reply
#10
I just never imagined that the Emulators are so CPU heavy and demanding god damn :l
I just cant imagine what computer you would need to have if there was a ps3 emulator
Reply




Users browsing this thread: 1 Guest(s)