Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS 3 looks blurry/ghosting on 1.6 but on 1.1 works perfectly except for missing text
#1
Video 
Hey there. My issue is that in PCSX2, MGS 3 subsistence US looks blurry no matter what I do. I wanted to change cause even tho it works perfectly on 1.1, it’s missing texts when you grab weapons etc as well as something really important, it’s missing subtitles on cutscenes and I really need them. So I downloaded 1.6 and been trying to fix it but god I gave up. If I could find a fix to missing text and subtitles for 1.1 i would just keep using that honestly.

My rig is a 1060 with an i5-4690.

Here you can see left one is 1.6 and right one 1.1 https://ibb.co/Kx4vs3N I am not sure how to refer to it if either ghosting or blurry

I found however that using Skipdraw Range completely removes the blurryness and looks sharp however it introduces some weird blue and red glitches on screen and if you keep increasing the values, then it just turns into a green half screen mirroring of the same game.

https://ibb.co/4VWZwrf
Reply

Sponsored links

#2
The blur comes from upscaling, and because of the upscale post-processing effects become misaligned. To fix that, choose Normal (Vertex) for Half-pixel Offset in Advanced Settings and Hacks in GSdx configuration window. Be sure to enable HW Hacks.
It also introduces the flickering and ghosting on upper and left corners of the screen, but i'm yet to discover a solution for that. It's unnoticeable during the gameplay so it's not a big of a deal. Aside from that, the game looks perfect.
Be sure to have automatic fixes and widescreen patches enabled, Fast-boot might introduce some differences(personally it fixed the post-processing flickering in older 1.5.0 builds)

Speaking of text displaying incorrectly, newer versions are not perfect in that regard either, but thankfully it's just the descriptions upon picking up weapons for the first time, other text displays as they should.
I didn't change anything in emulation settings, aside from enabling MTVU, GSdx settings look like this https://i.imgur.com/NOX6HVZ.png

Hope that helps.

P.S. If you're still having issues, you might consider trying out testing 1.7.0 git builds, been playing the game just fine on one of those using just the half-pixel offset hack.
Reply
#3
(09-02-2020, 08:04 AM)Oh mannikivarvar Wrote: The blur comes from upscaling, and because of the upscale post-processing effects become misaligned. To fix that, choose Normal (Vertex) for Half-pixel Offset in Advanced Settings and Hacks in GSdx configuration window. Be sure to enable HW Hacks.
It also introduces the flickering and ghosting on upper and left corners of the screen, but i'm yet to discover a solution for that. It's unnoticeable during the gameplay so it's not a big of a deal. Aside from that, the game looks perfect.
Be sure to have automatic fixes and widescreen patches enabled, Fast-boot might introduce some differences(personally it fixed the post-processing flickering in older 1.5.0 builds)

Speaking of text displaying incorrectly, newer versions are not perfect in that regard either, but thankfully it's just the descriptions upon picking up weapons for the first time, other text displays as they should.
I didn't change anything in emulation settings, aside from enabling MTVU, GSdx settings look like this https://i.imgur.com/NOX6HVZ.png

Hope that helps.

P.S. If you're still having issues, you might consider trying out testing 1.7.0 git builds, been playing the game just fine on one of those using just the half-pixel offset hack.

Oh man thanks so much! It’s finally working and looks sharp and good! Gonna go try see if cutscenes has subtitles now. But thanks again Laugh
Reply
#4
(09-02-2020, 08:04 AM)Oh mannikivarvar Wrote: The blur comes from upscaling, and because of the upscale post-processing effects become misaligned. To fix that, choose Normal (Vertex) for Half-pixel Offset in Advanced Settings and Hacks in GSdx configuration window. Be sure to enable HW Hacks.
It also introduces the flickering and ghosting on upper and left corners of the screen, but i'm yet to discover a solution for that. It's unnoticeable during the gameplay so it's not a big of a deal. Aside from that, the game looks perfect.
Be sure to have automatic fixes and widescreen patches enabled, Fast-boot might introduce some differences(personally it fixed the post-processing flickering in older 1.5.0 builds)

Speaking of text displaying incorrectly, newer versions are not perfect in that regard either, but thankfully it's just the descriptions upon picking up weapons for the first time, other text displays as they should.
I didn't change anything in emulation settings, aside from enabling MTVU, GSdx settings look like this https://i.imgur.com/NOX6HVZ.png

Hope that helps.

P.S. If you're still having issues, you might consider trying out testing 1.7.0 git builds, been playing the game just fine on one of those using just the half-pixel offset hack.

Oh man thanks so much! It’s finally working and looks sharp and good! Gonna go try see if cutscenes has subtitles now. But thanks again Laugh
Reply
#5
(09-02-2020, 04:59 PM)ColdVergil Wrote: Oh man thanks so much! It’s finally working and looks sharp and good! Gonna go try see if cutscenes has subtitles now. But thanks again Laugh

no problem! glad that helped
i have also noticed that you're using custom resolution, if i'm not mistaken it is recommended to use x2-x3 etc
but if you're not having any issues and the game looks and works just fine most of the time, leave it as it is
Reply
#6
(09-02-2020, 10:03 PM)nikivarvar Wrote: no problem! glad that helped
i have also noticed that you're using custom resolution, if i'm not mistaken it is recommended to use x2-x3 etc
but if you're not having any issues and the game looks and works just fine most of the time, leave it as it is

Oh yeah I switched that as well to x3 since I saw it in your settings! Thanks much again been playing and cutscenes do have subtitles!
Reply




Users browsing this thread: 1 Guest(s)