Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS2 - Good GPU, Bad FPS, Ugly Textures
#1
Lets start off with quick specs:

[Image: ead0e7869233bb3f7d5a75d082bc1ee3.png]

Problem:
Somehow I get better framerate dumping all the load on my CPU (software mode)
than when I divide the load and use GPU as well (hardware mode), and it makes no sense to me. What am I doing wrong?
Will I be forced to play through entire game in software mode?

The ugly textures dont worry me, it still looks good. What worries me if ill be able to complete the game using ONLY software mode if I dont find a way to use the power of my GPU thats just sitting there doing nothing.

Settings:
[Image: b7aa7aeb35f42edaa570948dc361addb.png]

[Image: 05366584941245842ab841b604e693d3.png]

Rest of the settings are (or should be) default.
-Yes, I do have the latest drivers.
-Yes I did try dx9 and dx11 and openGL rendering modes (hardware), and they all give me horrible slowdowns, freezes, and black screens forcing me to exit and resume the game as all I get is the sound back once it recovers.
Reply

Sponsored links

#2
DX11 would be best.

What are EE and GS% in title bar when running?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(06-21-2014, 12:25 AM)Blyss Sarania Wrote: DX11 would be best.

What are EE and GS% in title bar when running?

Ehhh, its being really weird. Outside on the deck I get 60fps using dx11 hardware (EE ~75% GS ~50%) and about 45fps using software mode.
But... once a fight/codec start I can stutter through it in software mode if needed, but in hardware mode it all just goes to hell instantly, black screen and all, like a driver crash I guess? Did have these problems before due to good old AMD cards and stuff.

On the inside I get stable 60fps on both hardware/software, but yet again, if I get a codec call or something I just black screen at some point during hardware rendering.
Im worried that (due to drivers?) I wont be able to play the game hardware mode, and I wont be able to finish the game rendering everything on CPU.

-Has someone done it before fully on software mode?
-Anyone else had problems with pcsx2+AMD graphic cards/drivers and has a fix for it like older drivers or some other plugin?

p.s. forgot to mention, using latest SVN build ofc.
Reply
#4
Are you running a proper AMD driver or a Microsoft one for that graphics card?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Software mode will work fine all the way through I am sure, but it will stop you from upscaling. Check what ref said.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
(06-21-2014, 12:55 AM)refraction Wrote: Are you running a proper AMD driver or a Microsoft one for that graphics card?

Latest Catalyst build ofc. Might try the BETA version though, didnt think of that.

(06-21-2014, 12:57 AM)Blyss Sarania Wrote: Software mode will work fine all the way through I am sure, but it will stop you from upscaling. Check what ref said.

Im glad to hear that, thanks! Just hope there wont be some 10fps boss fights in the rain. From what I read on the forums the starting level (the ship) is by far the worst when it comes to power demands. I hope it stays that way. Really would love to run the game hardware mode if I manage, but if not I guess ill go through it in software. Its an amazing game after all, and having native resolution rendered through CPU isnt all that horrifying.
Reply
#7
select your graphics card in the gsdx config.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#8
(06-21-2014, 01:07 AM)Nobbs66 Wrote: select your graphics card in the gsdx config.

[Image: 594c3602bbde16b77d1c66a0f1d3d801.png]

Its the only thing there, dont have an integrated card.
Selecting it doesnt change anything, tried it out.

Also:
[Image: 13a64dd00cab1f5de5a5898982f7381a.png]

Yap... sadly its my AMD drivers crashing. Actually saw on the taskbar this time "AMD drivers have crashed and recovered". Only other thing I get drivers crashes besides this emulator is Path of Exile, nowhere else and I played 100s of games on this amd7850 including Witcher2 on some crazy settings at stable 50fps+.
Reply
#9
In that case i would recommend reverting to an old driver.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(06-21-2014, 01:18 AM)refraction Wrote: In that case i would recommend reverting to an old driver.

That is a sad painful road to go through again, as I already did it once with Path of Exile (spent whole day doing clean driver re-installs one by one version).
Dont think it would change anything with pcsx2 either.
My card hates me and I've learned to live with it. As long as I can complete mgs2/3 in mainly software mode Ill gladly do it.

Thank you all for helping me figure out what was going wrong, and for giving me hope to actually complete these amazing games (+watch mgs4 on youtube then pray to whatever Deity would listen to me that MGSV gets a PC version).
Reply




Users browsing this thread: 1 Guest(s)